How JustAnswer Works:
  • Ask an Expert
    Experts are full of valuable knowledge and are ready to help with any question. Credentials confirmed by a Fortune 500 verification firm.
  • Get a Professional Answer
    Via email, text message, or notification as you wait on our site. Ask follow up questions if you need to.
  • 100% Satisfaction Guarantee
    Rate the answer you receive.
Ask vwnewton Your Own Question
vwnewton
vwnewton, VW Owner,ASE Master and L1 Advanced
Category: VW
Satisfied Customers: 307
Experience:  25 years of VW obsession turned into a job, last 15 years as a VW Tech.
13710235
Type Your VW Question Here...
vwnewton is online now
A new question is answered every 9 seconds

I have a customer with a 1999 Eurovan AES engine. He gets a

Customer Question

I have a customer with a 1999 Eurovan AES engine. He gets a consistent Code P0411 secondary air injection insufficient flow. This is the only copde present and comes on intermittently after long drives. The secondary air injection pump, Kombi Valve, Solenoid and all vacuum lines have been replaced. When the secondary air injection pump is activated through our VAG analyzer the pump runs and airflow is present. Could this be an O2 sensor issue?? No O2 codes and sensor appears to have good "sweep".
JA: Have you located all of the vehicle's oxygen sensors? Are the wires leading to and from each intact and in good shape?
Customer: I have inspected the sensor harnesses but not the vehicle O2 harnesses
JA: Are you fixing your Eurovan yourself? What have you tried so far?
Customer: I am a professional shop. we have a rebuilt VR6 engine and transmission in vehicle with around 15K miles since replacement
JA: Anything else you want the mechanic to know before I connect you?
Customer: This code occurs intermittently and I suspect it occurs during the 45 second runup on hot restart for the secondary air injection. I receive no O2 sensor codes. Could this be related to plugged tubes in exhaust manifold?
Submitted: 2 months ago.
Category: VW
Expert:  Wolfgang replied 2 months ago.

Thanks for choosing Just Answer . I'm Wolfgang here to help!!

I am confident we can resolve your problem together. Please
understand that I don't know your skill level. In most cases when you have a problem
with the way the vehicle performs, specialized tooling is required to acquire computer
data/information or engine testing results. We didn’t build these complicated vehicles; we
just diagnose and fix them. Also understand that I can't see, smell, hear, or touch the
vehicle either, so it may take a few replies to get to satisfactory results. Note there may be an issue where the complexity of the issue will require a Premium Service. This service will be an addition to the normal question cost. Usually it does not come down to this but keep in mind!! I am also going to direct you with the fastest, easiest and most common things to check first. Please be
patient and permit me to do what I do best.
I also try to give all of the information you may need, expecting a “positive rating” in
return. I will also continue assisting you after you have rated me, if necessary. If there
is any reason I cannot get a positive rating, please let me know why “in advance”, so I
can go another direction for you. I am sorry you’re having this problem; I’ll help you
through it.
Below is my first answer or request for more information. If you do not understand it, or you need more information from me, or need me to go in more detail.

what make and model scan tool you have?

i do need a vin # please.

thanks

Customer: replied 2 months ago.
Vin# ***** It is a camper MPV conversion. I am a former BMW Tech and Service manager with 40+ years of experience. I use a Ross-Tech Vag.Com program as well as an I-Scan W with full suite of Audi/VW software including programming capability. I can assure you My Technicians and I have covered the basics. Including manually triggering Secondary Pump, removing Kombi Valve and check airflow through the cylinder head. Secondary Air Blower, Kombi Valve and corrugated hoses, Control Solenoid and vacuum hoses are all New. Engine and cylinder head have about 15K miles on rebuilt.
Expert:  Wolfgang replied 2 months ago.

ok i do need to use vag com and i do need measured values of the mixture adapations at idle and part throttle . measured value block 32 and the grams per second of the mass air flow sensor either 001 or 002 post here.

once you have that then have the engine running go to basic settings 077 then turn test on then press and hold the brake pedal . let it run the test . after that then print the final readings after the test here

thanks

Customer: replied 2 months ago.
Will do, Give me a day to respond with values, my problem will be that I "feel" that the values become skewed after hot restart
during the 45 second runup of the Secondary air system. Tough to duplicate.
Expert:  Wolfgang replied 2 months ago.

the 077 is a direct test of the secondary air but must be at operating temp!!

Customer: replied 2 months ago.
Wolfgang, I'm sorry for the slow response, the customer and vehicle are currently out of town and will not return until next week at which time I will send you results
Expert:  Wolfgang replied 2 months ago.

please do thanks for the update

Customer: replied 2 months ago.
Wolfgang, I have the 99 Eurovan MPV back in the shop. Later today I will run VAG block 32, Basic setting 077 and email you the readings
Expert:  Wolfgang replied 2 months ago.

got it!

Customer: replied 2 months ago.
OK I have run VAG here is what I have:
block 32 Grams/sec at 76.5 c idle 3.06-3.12, part throttle 10.48-10.97 MAF sensor
MAF adaptation idle .09 g/sec part throttle .08 g/sec
O2 sweep idle -10.2 to -17.2% part throttle -8.4 to -23.2 %
O2 adaptation idle 7.0% part throttle 4.7%
catalyst temp 152 deg centigrade
no secondary air injection code or pending code
It is saying that basic setting 077 is not available and I have tried going to Output tests and can't trigger Sec AIJ?
Expert:  Wolfgang replied 2 months ago.

lets try basic settings 160 and run the test

Customer: replied 2 months ago.
I will try basic 160 but I think that wasn't available either. I did have a downstream O2 sensor fail due to intermittent inactivity
also the Catalytic Converter was very SLOW to heat up to 360 deg c operating temperature
Expert:  Wolfgang replied 2 months ago.

is the air filter plugged up ? make sure the snow screen , air inlet screen is not plugged up with debris. before filter

Customer: replied 2 months ago.
air filter is good, screen is good. I was able to induce 2 codes: Vag 16795 and 16524. I was able to activate the secondary air injection via basic 160 relay closed and pump ran no codes occurred
Expert:  Wolfgang replied 2 months ago.

at the end what was the readings of all 4 fields?

Customer: replied 2 months ago.
Here is the problem, on basic 160 it would only allow me to run test with engine OFF and brake pedal depressed. So no readings except for 00010000 in field 4. I am letting vehicle warm up and will try to run the test w/engine running
Expert:  Wolfgang replied 2 months ago.

the test must be running and possible the brake needs to be pressed to run the test!!

Customer: replied 2 months ago.
I was pressing brake, does parking brake have to be set?
Customer: replied 2 months ago.
Please go through the exact procedure to run the Secondary Air injection test with VAG software: I must be doing something wrong as I can run system key on engine off only. Give me a step by step list please
Customer: replied 2 months ago.
Am I correct in thinking that the secondary air injection flow is "measured" via the O2 sensor response at the catalyst?
Expert:  Wolfgang replied 2 months ago.

the field of the last field must read 00000100

that means test passed!!

Customer: replied 2 months ago.
OK Wolfgang, I figured out what I did wrong there can be no failure codes existing, so with secondary air injection code it kicked me out of test. Here are the warmed and running results in measuring block 160:
IDLE w brake applied field 1 94.5 deg field 2 0.8% field 3 0.0% field 4 11110000
THROTTLE w brake applied field 1 91.5 deg field 2 0.8% field 3 0.0% field 4 11010000
I have ordered a downsteam O2 sensor obviously but I am worried about the converter health
Expert:  Wolfgang replied 2 months ago.
Ok get the o2 in and then retest