How JustAnswer Works:
  • Ask an Expert
    Experts are full of valuable knowledge and are ready to help with any question. Credentials confirmed by a Fortune 500 verification firm.
  • Get a Professional Answer
    Via email, text message, or notification as you wait on our site. Ask follow up questions if you need to.
  • 100% Satisfaction Guarantee
    Rate the answer you receive.
Ask vwnewton Your Own Question
vwnewton
vwnewton, VW Owner,ASE Master and L1 Advanced
Category: VW
Satisfied Customers: 307
Experience:  25 years of VW obsession turned into a job, last 15 years as a VW Tech.
13710235
Type Your VW Question Here...
vwnewton is online now
A new question is answered every 9 seconds

How much do you guys charge for a question, I bought a 1999

Customer Question

how much do you guys charge for a question
JA: I'm not sure of the exact price, but there's only a $5 deposit. The rest of the price information will be on the page I send you to.
Customer: Hi I bought a 1999 VW beetle 2.0 automatic and it has a checkengine p0501. speedometer, odometer, cruise control, and gas light is always on. - i changed the sensor thats on the transmission and that didnt work, all fuses are fine, i checked to see if the sensor is getting electricity and it is, when i turn it with my hand with the key on the speedometer move so im thinking the cluster is fine, the rpm works fine. I also pugged in my obd scanner and the speed of the car is reading 0mph all the time
JA: While using the cruise control can you accelerate or decelerate? Have you checked the fuses?
Customer: cruise doesnt work
JA: Anything else you want the mechanic to know before I connect you?
Customer: nope
Submitted: 4 months ago.
Category: VW
Customer: replied 4 months ago.
Im sorry i meant speedometer, odometer and cruise control doesnt work, gas gauge work but the gas light is always on
Expert:  Gunvir Singh replied 4 months ago.

Hello, how long does it take for the code p0501 to come back after you clear it?

Customer: replied 4 months ago.
like 3-4 miles
Expert:  Gunvir Singh replied 4 months ago.

Is this the sensor that you replaced?

Customer: replied 4 months ago.
i replaced the sensor and the bearing that goes in the transmission
Customer: replied 4 months ago.
thats the one
Expert:  Gunvir Singh replied 4 months ago.

Since the senor has been replaced need to make sure wiring is good.

1. The G22 VSS is a Hall Effect style sensor. Check pin #1 at the sensor for 12 volts with the ignition on and the engine running.

2. Check pin #3 for a constant good ground at all times.

3. Pin #2 receives a reference voltage produced in the Instrument Cluster Speedometer Head and will show 5 to 11 volts (a faulty speedometer head may fail to output the reference voltage to the G22 VSS).

Customer: replied 4 months ago.
I did checked the pin 1 and 3 and I have ground on 3 and 12v on 1
Customer: replied 4 months ago.
with key on engine off i was getting 0 on pin 2
Customer: replied 4 months ago.
you dont think that the bearing thats in the tranmission that turns the speed sensor is broken ?
Customer: replied 4 months ago.
because when i turn it with my hand it moves the speedometer
Expert:  Gunvir Singh replied 4 months ago.

Ok, that's what the next test was. If the reading is present when you turn the sensor by hand then the problem is in the drive gear.

Customer: replied 4 months ago.
thats what i was thinking, but when im driving and i floor the pedal the speedometer goes up like 5mph then goes down and the car only has 30,000 miles
Expert:  Gunvir Singh replied 4 months ago.

The gears are probably worn out and start slipping when you accelerate.

Customer: replied 4 months ago.
i replaced the driver gear that connects to the speed sensor and goes in the transmission 2 times with no luck
Customer: replied 4 months ago.
when i turn it with my hand with the key on i see the speedometer moving a little bit
Expert:  Gunvir Singh replied 4 months ago.

With everything connected if clean square wave signal is present on pin #2 of the G22 VSS and there is still no speedometer function, the speedometer head in the instrument cluster is faulty.

Customer: replied 4 months ago.
Im sorry man it doesnt make sense because the speedometer turns when i do it with hand, and if the speedometer head is the problem why the gas gauge is acting weird and the cruise control
Customer: replied 4 months ago.
how can i test to see if the piece in the transmission that turns the drive gear is working properly ?
Expert:  Gunvir Singh replied 4 months ago.

Since the sensor and gear have already been replaced and the connector has signal present at all three pins at ignition on. Only components left are speedometer and the internal transmission gear. To check the internal transmission gear the transmission will need be taken apart. Before going that route the need to make sure speedomeer is not at fault. The sensor provides signal to the speedomer and then the pcm. A faulty speedometer will not provide proper signal to the ecm.

Customer: replied 4 months ago.
but why the speedometer turns when i turn with my hand the gear if the speedometer is bad
Expert:  Gunvir Singh replied 4 months ago.

It only works till a certain reistance.

Expert:  david craig replied 4 months ago.

Hi Im David, your problem is internal of the transmission. its either a worn driven gear that the output shaft drives or the out put shaft