How JustAnswer Works:
  • Ask an Expert
    Experts are full of valuable knowledge and are ready to help with any question. Credentials confirmed by a Fortune 500 verification firm.
  • Get a Professional Answer
    Via email, text message, or notification as you wait on our site.
    Ask follow up questions if you need to.
  • 100% Satisfaction Guarantee
    Rate the answer you receive.
Ask Edward Your Own Question
Edward
Edward, ASE Certified Technician
Category: Volvo
Satisfied Customers: 3077
Experience:  I've had 10 years of experience on the car line at 2 Volvo dealerships, Quality level Volvo tech.
29534642
Type Your Volvo Question Here...
Edward is online now
A new question is answered every 9 seconds

Volvo Volvo S60: I bought a 02 S60 last November. Recently

Customer Question

I bought a 02 S60 last November. Recently I have had a problem and don't quite understand what the problem may be. I took the air control module out with the battery connected, dumb mistake and it threw up the SRS airbag urgent message, I know I need to get it cleared but about a week after I would crank the car and it would idle like crap, then it went into limp mode. Next morning I cranked it it was fine. Ran great for 3 or 4 days and then had another episode so I had the codes popped and it came off P177 and P1026. I sea foamed it and cleaned the MAF sensor with maf sensor cleaner, took the plugs out and cleaned them, ran like a top 39 miles to work this morning and at lunch as well. Came out and cranked it in the heat of the day (As all the other times I have had problems) and it ran like crap. 20 minutes later it started and ran like a champ. I have replaced the fuel filter and Changed the MAF sensor out with one that was T boned (same part number) I got better gas milage this morning than I had ever got before averaging 31.4 to work. I didn't want to chance the drive in traffic hour so I drove a company vehicle home and we plan on checking the pressure on the rail in the morning. What do you think it may be, can't have it going down in limp mode like this during traffic hour.
Submitted: 2 years ago.
Category: Volvo
Expert:  Edward replied 2 years ago.
Hello, Eddie here and I will do all I can to help. With those codes and that symptom, I really believe your ETM is failing. The Electronic Throttle Module. Usually if it runs at all, fuel pressure isn't the issue (it's usually either got enough pressure or it doesn't). And the ETM is the most common culprit of it going into that limp mode. Also, your P1026 points to that component being failed. Dealer will want 1200$ likely for that repair. That is for a new one and the software download it takes. However, Xemodex.com is the alternative. You can ship them your old one, and they can rebuild it, or you can request a new unit, with software already downloaded and then you just replace it and plug it in and your good to go. I believe you'll find your problem there. Let me know if you have any further questions. Thank you.
Expert:  Edward replied 2 years ago.
Any luck with that?