How JustAnswer Works:
  • Ask an Expert
    Experts are full of valuable knowledge and are ready to help with any question. Credentials confirmed by a Fortune 500 verification firm.
  • Get a Professional Answer
    Via email, text message, or notification as you wait on our site. Ask follow up questions if you need to.
  • 100% Satisfaction Guarantee
    Rate the answer you receive.
Ask Pete Your Own Question
Pete
Pete, Electronic Engineer
Category: Camera and Video
Satisfied Customers: 18137
Experience:  Over 16 years of experience installing and repairing electronics.
30970729
Type Your Camera and Video Question Here...
Pete is online now
A new question is answered every 9 seconds

Just brought a sony a 6000. kit. 16-50 works fine but 55-210

Customer Question

Hello, Just brought a sony a 6000. kit. 16-50 works fine but 55-210 will not focus. Series of 14 click click clicks Do I have the settings all wrong. 16-50 works fine but when I change lens but not alter any settings 55-210 will not focus except for small area very close up (Like macro) when I move camera back and forth
JA: What's the exact make and model of the camera? And can you guesstimate how old it is?
Customer: A6000 and about a month ago purcchased on line from WA.
JA: How long has this been going on? What troubleshooting have you tried?
Customer: Happened two days ago and then again this morning. Am at Huntington Beach for surfing contest. When I change lens to long one there is a series of 14 click click clicks like it is searching. Spoke to dealer and went through all their suggestions. they advised call you. as sounds like problem lens
JA: Anything else you want the electronics expert to know before I connect you?
Customer: Perhaps advise expert am electrically challenged so should use simple terms as though talking to an imbecile.
Submitted: 2 months ago.
Category: Camera and Video
Expert:  Pete replied 2 months ago.

Hi, I'm Pete. Welcome to JustAnswer! I'm reviewing your question now, and will post back with your reply ASAP.

Expert:  Pete replied 2 months ago.

Are you using manual or automatic focus? Can you try using the other type of focus and let me know if it works at all?
Can you also try removing the lens and cleaning the electronic contacts on both the lens and the camera body?