How JustAnswer Works:
  • Ask an Expert
    Experts are full of valuable knowledge and are ready to help with any question. Credentials confirmed by a Fortune 500 verification firm.
  • Get a Professional Answer
    Via email, text message, or notification as you wait on our site. Ask follow up questions if you need to.
  • 100% Satisfaction Guarantee
    Rate the answer you receive.
Ask Richard Your Own Question
Richard
Richard, Technician
Category: Camera and Video
Satisfied Customers: 38523
Experience:  Extensive knowledge in a very wide range of subjects
32989067
Type Your Camera and Video Question Here...
Richard is online now
A new question is answered every 9 seconds

When I try to download photos from my EOS Rebel XT to my

Customer Question

when I try to download photos from my EOS Rebel XT to my IMac - which works fine up til today - It flashes 'busy' in the menu box
JA: What's the make/model of your camera? How old is it?
Customer: Canon EOS digital Rebel XT - first one produced - Also says EOS 350D Digital
JA: What happened right before this popped up? What troubleshooting have you tried?
Customer: I did try to re set some things - not sure what caused this
JA: Anything else you want the camera expert to know before I connect you?
Customer: NO thanks
Submitted: 11 months ago.
Category: Camera and Video
Expert:  Richard replied 11 months ago.

Hi there and welcome

Can you do the following please

  1. Shut down your Mac.
  2. Find Command (⌘), Option, P, and R on your keyboard.
  3. Turn on your Mac.
  4. Press and hold the Command-Option-P-R keys immediately after you hear the startup sound.
  5. Hold these keys until the computer restarts and you hear the startup sound for a second time.
  6. Release the keys.

Then tell me if the camera is detected correctly

Let me know the results please.

Customer: replied 11 months ago.
Nothing changed and I was able to download from another camera. I think it's the camera settings.
Expert:  Richard replied 11 months ago.

Can you remove the battery please then hold the shutter button down for 60 seconds then release.

Wait 5 minutes, put the battery back in and try to turn it on.

Tell me please if it now connects

Thank you

Customer: replied 11 months ago.
I did the above. As before the PHOTO app on my imac opened and showed the canon rebel, but the camera still flashes BUSY and there is no option to download.
Expert:  Richard replied 11 months ago.

ok, please disconnect the camera

Press the "Menu" button on the back of the Canon Rebel XT and to the left of the LCD screen to access the main menu. You will notice five tabs across the top of the screen.

Push the "Jump" button, which is located below the "Menu" button on the back of the camera, until the last tab is selected. The last tab is "Set-up Menu 2," and has a symbol of a wrench next to a hammer and a "2."

Press the down arrow button on the back of the camera until "Clear All Camera Settings" is highlighted, and then press the "Set" button. The "Set" button is located in the middle of the arrow buttons, which are found to the right of the LCD screen. A confirmation screen that reads "Clear All Camera Settings" appears.

Push the right arrow button to highlight "OK," and then press the "Set" button to reset all of the settings to their defaults.

Then tell me if it connects please

Customer: replied 11 months ago.
Clear all camera setting was not an option. I did change the hour to be correct. Still same response when trying again.
Expert:  Richard replied 11 months ago.

ok, you may have a different firmware, look for clear settings please

Customer: replied 11 months ago.
Richard, I'm going to look at my owner's booklet again for ways to clear the settings, since nothing shows up under menu or info. Will get back to you.
Customer: replied 11 months ago.
It needed to be in advanced mode to show 'clear settings'. Hard to say if I actually cleared them because it kept wanting me to cancel that. Still busy when connected to computer but does take photos. Should I clear 'custom settings?
Expert:  Richard replied 11 months ago.

yes, clear customer settings, then restart the computer and try to connect it please

If it fails, try a different memory card in the camera please

Customer: replied 11 months ago.
I'm going to have to take a break from this until after Thanksgiving. Will order a new memory card. Have a great Thanksgiving Richard and I'll get back to you re my progress. Best - Cassandra
Expert:  Richard replied 11 months ago.

Thank you Cassandra.

Customer: replied 11 months ago.
Hi Richard. I wanted to let you know what got the camera to be recognized by the photo app on my 1mac OSX with El Capitan version 10.11.6. Then I'll leave your feedback.When I got the computer - pretty recently - it wouldn't download photos from this camera. Then I read on a blog online that under menu, moving to the last (farthest right) place at the top, I needed to change communication from PC Connection to PTP - which worked. Well for some reason, when I changed it back to PC connection, it is now working. Just thought if this comes up again you should know. It's possible that if resetting settings as you suggested had actually worked it would have happened then. Thanks for all you help! ~Cassandra
Expert:  Richard replied 11 months ago.

Thank you for the feedback Cassandra

I have never had the need to change it so it is strange, as PTP is for live view transfer.

But good work here! and if you ever need anything else please let me know!

Richard