How JustAnswer Works:
  • Ask an Expert
    Experts are full of valuable knowledge and are ready to help with any question. Credentials confirmed by a Fortune 500 verification firm.
  • Get a Professional Answer
    Via email, text message, or notification as you wait on our site. Ask follow up questions if you need to.
  • 100% Satisfaction Guarantee
    Rate the answer you receive.
Ask Cardoctor69 Your Own Question
Cardoctor69
Cardoctor69, Ase certified technician
Category: UK Nissan
Satisfied Customers: 25955
Experience:  Ase Master Tecnician
3827149
Type Your UK Nissan Question Here...
Cardoctor69 is online now
A new question is answered every 9 seconds

According: nissan..code reader, fault code..oxygen sensor

Customer Question

my car nissan almera 2001, 1.5, mamual, engine warning light on for certain time,according to snap on code reader, fault code was p0141 heater circuit problem on bank 1 oxygen sensor 2.
things i"ve done:
1. managed to change no. 2 sensor, light still on, drive round blocks 10 mins, light still on
2. :::: to check the voltage of no 1. sensor(by the cat), it read 356mv, try to
check no.2 sensor volt, weather getting dark, and 4 wires on the plug, dont know which is which, gave up.(when checking no.1 sensor volt, eng was idling speed)
3. all wires ,fues, seems ok, except ecm plug connection( could not find location)
please help :
1. how to repair this circuit problem
2. do i have to check all the sensors one by one
3. how to check ecm
4. is the mixture too lean, how to tune it up
5. location of ecm unit
6. if battery is disconneted,will the fault codes come back again
7. by the right hand side of engine bay, there is a small rectangular rely box,one main
relay missing, doest it matter
8. please show me the right path to get rid this light,many many thanks!!!!!!!!!!!!!!!!!!
Submitted: 6 years ago.
Category: UK Nissan
Expert:  Cardoctor69 replied 6 years ago.
This is the only code stored?
Customer: replied 6 years ago.
hi cardoctor 69, can u tell me what more information do u need ?
Customer: replied 6 years ago.
hi cardoctor 69, can u tell me what more information do u need ?

Expert:  Cardoctor69 replied 6 years ago.
I just need to know if there were any other codes stored?
Customer: replied 6 years ago.
NO, ONLY ONE , THANKS,
Expert:  Cardoctor69 replied 6 years ago.
Check the blue wire with the yellow stripe at the back of the connector of the sensor these break all the time let me know if it's broken.
Customer: replied 6 years ago.
THEY ARE NOT BROKEN ,THANKS
Customer: replied 6 years ago.
THEY ARE NOT BROKEN ,THANKS

Expert:  Cardoctor69 replied 6 years ago.
Ok has the mass air flow sensor been checked? Was there any work done prior to this happening?
Customer: replied 6 years ago.
hi, cardoctor69, a lot of sensors volts behave funny, especially maf, let me list them,
maf-------------engine idling-----flucuating between 14.1v to 181.8 mv
maf-------------2500rpm-------------14.2v
maf-------------ignition on------------12.04v
earth----------ignition on--------------7.42v
evap valve-----ignition on-----------8.4mv
egr-------ignition on temp 0 degree-------12.2v
egr-------engine running 100 degree------14v
iat--------ignition on----------12.21v ,i will double check them ,thanks
Expert:  Cardoctor69 replied 6 years ago.
Honestly I would start with the maf sensor next .
Customer: replied 6 years ago.
hi, cardoctor69, i put the maf sensor, light is on, what else u can think of , please tell me what to do next to solve the problem( warning light still on),before i pay,thanks,