UK Car

UK car repair questions? Ask a mechanic for answers ASAP

Ask an Expert,
Get an Answer ASAP!

Ford F250 2005 6.0 diesel, cuts out when it gets up to temp,

Customer Question
Ford F250 2005 6.0...

Ford F250 2005 6.0 diesel, cuts out when it gets up to temp, gauges read normal. let it cool down for 7 minutes, starts right up. If I run it with cab heater on full it will run all day. We have replaced the Crank position sensor but it made no difference.

Mechanic's Assistant: Does the vehicle stall at low speeds? Does it sputter?

No

Mechanic's Assistant: Are you fixing your F250 yourself? What have you tried so far?

Yes we have a fitter here, so far we have changed the crank sensor. we are trying to figure out what component would be able to turn the engine off when it is running, and be able to let it start again when it cooled down again. all the gauges read normal.

Mechanic's Assistant: Anything else you want the mechanic to know before I connect you?

We have bought a new thermostat , new coolant temp sensor, new cam position sensor, new icp sensor and new ipr sensor. not fitted yet.

Submitted: 8 months ago.Category: UK Car
Show More
Show Less
Ask Your Own UK Car Question
Customer reply replied 8 months ago
we have now changed the thermostat, coolant temp sensor, cam position sensor. Started right up after changes, brought it up to temperature, drove it, it ran fine. Turned it off now it is no start.
Answered in 9 hours by:
11/17/2017
UK Auto Mechanic: Scott W., ASE Certified Technician replied 8 months ago
Scott W.
Scott W., ASE Certified Technician
Category: UK Car
Satisfied Customers: 3,609
Experience: 28 yrs. experience in automotive repair
Verified
Hello my name is***** you checked for trouble codes?
Ask Your Own UK Car Question
UK Auto Mechanic: Scott W., ASE Certified Technician replied 8 months ago
Do you have a scan tool that will look at pids?
Ask Your Own UK Car Question
Customer reply replied 8 months ago
I have a Foxwell scan tool, I have scanned it today and codes coming up are - Instrument cluster fault 13 - Powertrain control module fault 17 . - Generic electronic control module fault 13. It started ok this morning but I have not run it up to temp yet. I don't have anyway to tell what these codes mean.
regards,
Ceri
Customer reply replied 8 months ago
My fitter is not in on a Saturday and we are in England. If I knew what the codes meant it would help.Regards,Ceri
UK Auto Mechanic: Scott W., ASE Certified Technician replied 8 months ago

I​ have no idea what type of codes those are, there should be a PXXXX code stored, specifically I am suspecting a P2291 low icp during crank. Your description sounds like there is a high pressure oil leak inside the engine. This can be caused by a IPR valve, block off plug, high pressure pump, standpipe, fuel injector, or stc fitting or the least common the branch tube. Since this only happens hot, I would make sure you have a P2291 code first, then look at ICP pid during the no start while cranking, if the pressure is less than 500 psi cranking during the no start, it will not start, the computer needs to see more than 500 psi before it will even fire the injectors. I suspect either the IPR valve or the STC fitting on the pump to branch tube, these were known for blowing the oring and causing a loss of high pressure oil. Let me know what the ICP is reading during the no start. Thanks Scott

Ask Your Own UK Car Question
Customer reply replied 8 months ago
IPR is at 16 to 25% when running, turned the engine off when up to temp (66c coolant tem). no start when tried to restart, IPR at 85% when cranked, no start. We tried to remove the IPR yesterday to replace it. Couldn't budge it, not enough purchase on a 2ft bar, do we have to remove the turbo to get it off? or is there another way.
Regards,
Ceri
UK Auto Mechanic: Scott W., ASE Certified Technician replied 8 months ago

I assume you have the IPR socket?

Ask Your Own UK Car Question
Customer reply replied 8 months ago
We saw one on a youtube vid and made one out of a an impact socket. Can you recommend a better scan / code reader that will give us the proper fault codes.
UK Auto Mechanic: Scott W., ASE Certified Technician replied 8 months ago

S​ince you have 85% ipr during the no start, you must have a high pressure oil leak for sure. I would apply power and ground to the ipr and remove the ICP sensor and air test the system listening for a air leak. I suspect the STC fitting on the pump, as 2005's we known for this failure. A scan tool to use for the diesels has to be a high end scanner, any snap on scanner will work, they are expensive.

Ask Your Own UK Car Question
Customer reply replied 8 months ago
Could it be the IPR valve is faulty? What I don't get is why it's temperature related to such a fine degree, keeping the cab heater on full stops the no start.
UK Auto Mechanic: Scott W., ASE Certified Technician replied 8 months ago

Yes we have seen IPR's do this exact problem, also the oil thins to a certain viscosity at a certain temp, so when the temp is reached, and there is a small leak, the pump can't over come this resulting in a no start. The first step Ford has us do with this type of problem is replace the IPR with a new or known good one and retest, we have a test IPR just for these types of problems.

Ask Your Own UK Car Question
Customer reply replied 8 months ago
ok so we seem to have solved the IPR no start when hot issue by replacing the IPR, now we are ok at idle but very lumpy response past 1200rpm, on scan I have no turbo boost, VGTDC turbo is at 73% on tickover and55% @ 1200rpm, past this point (1200rpm) it gets real lumpy. Key on engine off- ICP is at .25v reading 23to 25 KPA and 1.25v running 1200rpm. IPR is 15% cold start on tickover and 19% @ 1200rpm. Manifold pressure is 97kpa key on engine off and 99kpa running 1200rpm. ficam is at 47.5V cold startup. So, starts fine and ticks over like a sewing machine, starts when hot but runs real lumpy at 1100 1200rpm, no turbo boost. Any ideas?
Ceri
UK Auto Mechanic: Scott W., ASE Certified Technician replied 8 months ago
Has the egg valve been pulled and made sure it’s not stuck open slightly?
Ask Your Own UK Car Question
Customer reply replied 8 months ago
Egr has been removed/blocked off 4 years ago. If I unplug the ICP then the IPR runs up to 30% but still no turbo boost.
UK Auto Mechanic: Scott W., ASE Certified Technician replied 8 months ago
Either the turbo vanes are stuck or the map hose or map port in intake is plugged or you have a blown out charge air cooler or hose. These are most common especially the plugged map port in the manifold.
Ask Your Own UK Car Question
UK Auto Mechanic: Scott W., ASE Certified Technician replied 8 months ago
Oh and make sure turbo is spinning and not seized.
Ask Your Own UK Car Question
Customer reply replied 8 months ago
We have stripped the turbo and cleaned it, spins ok and vanes move. The turbo actuator/ works when we put 12v to it out on the bench. Since the engine seems to be hunting at higher revs and the turbo is not kicking in I am wondering if the two issues are linked by the IPR showing full bypass at 15% cold and running at tickover. The injectors need higher oil pressure when the revs are increased and also the turbo needs hp oil to open the vanes I think? When I unplug the Icp the IPR pressure goes up to 30%. So I am thinking maybe the old and new replacement are duff . We will look at the map port and see if it is clean / clear. I thank you for your continued input and will be sure to pay what is appropriate when we resolve this. Regards,
Ceri
Billesdon
LE79FY
England
You can find us on Google earth.
UK Auto Mechanic: Scott W., ASE Certified Technician replied 8 months ago
15 percent ipr is a good reading usually anything over 20-25 indicates high pressure oil loss. Has the fuel pressure been checked it needs to be 50.
Ask Your Own UK Car Question
Customer reply replied 7 months ago
Sorry its taken a while to get back to you, we had to wait to get a new ICP sensor. We got the truck working, the main issue was the IPR valve, no start when hot. The problem following that was the ICP sensor, someone sent us the wrong one, then we found when we fitted the new one that one of the terminals on the 3 pin plug to the ICP was not making proper connection. Thanks for your help, how can I pay you?
Regards,
Ceri
Was this answer helpful?

How JustAnswer works

step-image
Describe your issueThe assistant will guide you
step-image
Chat 1:1 with an uk auto mechanicLicensed Experts are available 24/7
step-image
100% satisfaction guaranteeGet all the answers you need
Ask Scott W. Your Own Question
Scott W.
Scott W.
Scott W., ASE Certified Technician
Category: UK Car
Satisfied Customers: 3,609
3,609 Satisfied Customers
Experience: 28 yrs. experience in automotive repair

Scott W. is online now

A new question is answered every 9 seconds

How JustAnswer works:

  • Ask an ExpertExperts are full of valuable knowledge and are ready to help with any question. Credentials confirmed by a Fortune 500 verification firm.
  • Get a Professional AnswerVia email, text message, or notification as you wait on our site. Ask follow up questions if you need to.
  • 100% Satisfaction GuaranteeRate the answer you receive.

JustAnswer in the News:

Ask-a-doc Web sites: If you've got a quick question, you can try to get an answer from sites that say they have various specialists on hand to give quick answers... Justanswer.com.
JustAnswer.com...has seen a spike since October in legal questions from readers about layoffs, unemployment and severance.
Web sites like justanswer.com/legal
...leave nothing to chance.
Traffic on JustAnswer rose 14 percent...and had nearly 400,000 page views in 30 days...inquiries related to stress, high blood pressure, drinking and heart pain jumped 33 percent.
Tory Johnson, GMA Workplace Contributor, discusses work-from-home jobs, such as JustAnswer in which verified Experts answer people’s questions.
I will tell you that...the things you have to go through to be an Expert are quite rigorous.

What Customers are Saying:

Wonderful service, prompt, efficient, and accurate. Couldn't have asked for more. I cannot thank you enough for your help.

Mary C.Freshfield, Liverpool, UK

This expert is wonderful. They truly know what they are talking about, and they actually care about you. They really helped put my nerves at ease. Thank you so much!!!!

AlexLos Angeles, CA

Thank you for all your help. It is nice to know that this service is here for people like myself, who need answers fast and are not sure who to consult.

GPHesperia, CA

I couldn't be more satisfied! This is the site I will always come to when I need a second opinion.

JustinKernersville, NC

Just let me say that this encounter has been entirely professional and most helpful. I liked that I could ask additional questions and get answered in a very short turn around.

EstherWoodstock, NY

Thank you so much for taking your time and knowledge to support my concerns. Not only did you answer my questions, you even took it a step further with replying with more pertinent information I needed to know.

RobinElkton, Maryland

He answered my question promptly and gave me accurate, detailed information. If all of your experts are half as good, you have a great thing going here.

DianeDallas, TX

< Previous | Next >

Meet the Experts:

Marty

Marty

European Car Expert

432 satisfied customers

ASE & Bosch Certified Master Tech. Over 30 years experience.

Greg

Greg

Shop Owner

1,366 satisfied customers

17 years Shop Owner /Technician. 27 years experience,

Richard

Richard

UK Car Mechanic

627 satisfied customers

12 years as a technician at a Ford and Jaguar dealer Ford and Jaguar factory certified

Matt

Matt

Mechanical Engineer

4,705 satisfied customers

BEng hons Mech engineering, in auto industry 22 years

Trevor

Trevor

UK Car Mechanic

853 satisfied customers

NVQ 3, Modern Apprenticeship, MOT Tester, 15+ years experience diagnostic technician

Rob

Rob

UK Car Mechanic

823 satisfied customers

city and guilds level 1 2and 3. mot tester , 28 years experience set up training college in afghanistan

martin jones

martin jones

UK Car Mechanic

646 satisfied customers

25 years as a mechanic and mot tester, owned own business for 10 years city and guilds trained

< Previous | Next >

Related UK Car Questions
Overheating replaced the thermostat and housing. Not losing
mechanic has replaced the thermostat and housing and cap … read more
Pete
Pete
Independent Auto Technician
Vocational, Technical or Trade Scho
138 satisfied customers
Temperature is fluctuating - well the gauge says it is! 104k
temperature is fluctuating - well the gauge says it is! … read more
Pete
Pete
Independent Auto Technician
Vocational, Technical or Trade Scho
138 satisfied customers
I have similar problem with 98 polo which has had new
I have similar problem with 98 polo which has had new combined temp sender (yellow) and fan control unit thermostat housing/thermostat radiator flush and refill by local garage but temp gauge did not … read more
Ross
Ross
Automotive Technician/Conaultant
Vocational, Technical or Trade Scho
470 satisfied customers
Ford Mondeo tdci: Sean,I have a problem with my engine
Hi Sean, I have a problem with my engine staying to cool. I copied a text from the website, since it describes my problem well: Hi, my 2004 Ford Mondeo 2.0 TDCi has recently started to run cool as ind… read more
sprinkles08
sprinkles08
Technician
High School or GED
11 satisfied customers
Jaguar X-Type: Hi Richard i have a 2005 2.0 diesel jaguar x
Hi i have a 2005 2.0 diesel jaguar x type last week i drove the car for 20 minutes and the temperature needle suddenly shot to red I got a high temperature warning in the dashbord. The car does not se… read more
Richard
Richard
UK Car Mechanic
Vocational, Technical or Trade Scho
627 satisfied customers
110 defender: I have a 1986 2.5 l landrover 110 defender non
I have a 1986 2.5 l landrover 110 defender non turbo and was driving when the temp gauge went almost into the red then went back almost to the middle, could it be thermostat or poss temp sensor proble… read more
Mark
Mark
348 satisfied customers
i have a 2000 vauxhall astra that always runs with no temp
i have a 2000 vauxhall astra that always runs with no temp on gauge , rac said he thinks its the thermostat stuck open but all forums say its a commen fault with no one saying they've had it replaced … read more
Mark
Mark
348 satisfied customers
Polo: I have a Polo 1.4, year 2000 ( Oct). Original problem
I have a Polo 1.4, year 2000 ( Oct). Original problem - no heat coming through the heater. As far as I remember, the temperature gauge was showing normal (90 degrees).The garage has put in a new therm… read more
Ross
Ross
Automotive Technician/Conaultant
Vocational, Technical or Trade Scho
470 satisfied customers
new radiator fitted and new fan on citroen xsara..stationary
new radiator fitted and new fan on Citroen Xsara still overheating. advice please only overheating when stationary… read more
Rob
Rob
UK Car Mechanic
Vocational, Technical or Trade Scho
823 satisfied customers
vauxhall zafira Hi , I have just bought my first Vauxhall,
Hi , I have just bought my first Vauxhall, a Zafira 1.6i 16v (2000) 62k Have owned the car for a couple of weeks, starts and runs great, however I did notice the temp gauge was only moving about a 1/4… read more
vauxdoc
vauxdoc
Vocational, Technical or Trade Scho
Head gasket done new radiator thermostat water pump fitted
had head gasket done new radiator thermostat water pump fitted to my rover 414 had a hot heater now heater gets to warm only on tick over temp goes to normal but when i drive the temp drops to zero so… read more
Bill_Crosby
Bill_Crosby
City & Guilds
2,608 satisfied customers
cooling fans..1998 406 diesel, the fans are not working..temp gauge
Hello can anyone advise on a problem i have with cooling fans not coming on. I have a 1998 406 diesel, the fans are not working even when the temp gauge is over 90c. Also the gauge is not even reachin… read more
Bill_Crosby
Bill_Crosby
City & Guilds
2,608 satisfied customers
Temperature Warning light stays on, temp guage goes from 0..Radiator
Megane Scenic RXE Auto 1998cc 1997. Temperature Warning light stays on, Temp guage goes from 0 to V.Hot in less than 1Km. Radiator full, engine does not seem hot, no oil burning off the block. Heater … read more
wefwef
wefwef
Vocational, Technical or Trade Scho
305 satisfied customers
Polo..slow moveing traffic or at idle..petrol..cheers
Hi there, I have a 1995 wv polo. The temperature guage does not seem to heat up when driving around in normal conditions but then will shoot up when in slow moveing traffic or at idle. I have checked … read more
FiestaEAC
FiestaEAC
Diagnostic Mechanic
Vocational, Technical or Trade Scho
61 satisfied customers
2002 x type: petrol..jaguar..which overheats, the heater..gets hot
I have a 2.1 2002 x type petrol jaguar which overheats, the heater gets hot and no lose of water, no sign of head casket gone?… read more
gemmechanic
gemmechanic
Diesel Teacher
Vocational, Technical or Trade Scho
130 satisfied customers
Gauge..acceleration..the coolant in the reservoir disappears (coolant
Pajero 3.2 DiD 2002: Heat gauge rises to higher than normal, close to redline, after a few kilometers travel and then comes down again to norm. The same happens after any harsh acceleration. Could it … read more
gemmechanic
gemmechanic
Diesel Teacher
Vocational, Technical or Trade Scho
130 satisfied customers
fuel pump on a 04 navara with out the diagnostic machine..much diesel
can you reset the fuel pump on a 04 navara with out the diagnostic machine it seems to put to much diesel in on start up hot or cold… read more
andy
andy
city and guilds
252 satisfied customers
Focus sel: a cooling problem ....when driving the temp..stays..pull
hi can u help my 1.8 focus disel has a cooling problem ....when driving the temp is fine stays middle of temp and gets nice and hot when selected and cold when selected but when i pull up and sit at s… read more
Matt
Matt
Mechanical Engineer
Bachelor's Degree
4,705 satisfied customers
Disclaimer: Information in questions, answers, and other posts on this site ("Posts") comes from individual users, not JustAnswer; JustAnswer is not responsible for Posts. Posts are for general information, are not intended to substitute for informed professional advice (medical, legal, veterinary, financial, etc.), or to establish a professional-client relationship. The site and services are provided "as is" with no warranty or representations by JustAnswer regarding the qualifications of Experts. To see what credentials have been verified by a third-party service, please click on the "Verified" symbol in some Experts' profiles. JustAnswer is not intended or designed for EMERGENCY questions which should be directed immediately by telephone or in-person to qualified professionals.

Disclaimer: Information in questions, answers, and other posts on this site ("Posts") comes from individual users, not JustAnswer; JustAnswer is not responsible for Posts. Posts are for general information, are not intended to substitute for informed professional advice (medical, legal, veterinary, financial, etc.), or to establish a professional-client relationship. The site and services are provided "as is" with no warranty or representations by JustAnswer regarding the qualifications of Experts. To see what credentials have been verified by a third-party service, please click on the "Verified" symbol in some Experts' profiles. JustAnswer is not intended or designed for EMERGENCY questions which should be directed immediately by telephone or in-person to qualified professionals.

Show MoreShow Less

Ask Your Question

x