How JustAnswer Works:
  • Ask an Expert
    Experts are full of valuable knowledge and are ready to help with any question. Credentials confirmed by a Fortune 500 verification firm.
  • Get a Professional Answer
    Via email, text message, or notification as you wait on our site. Ask follow up questions if you need to.
  • 100% Satisfaction Guarantee
    Rate the answer you receive.
Ask Peter Zavarelli Your Own Question
Peter Zavarelli
Peter Zavarelli,
Category: UK Car
Satisfied Customers: 34829
Experience:  Technical Consultant at Just Answer
14928985
Type Your UK Car Question Here...
Peter Zavarelli is online now
A new question is answered every 9 seconds

I have citroen zsara picasso diesel i was installing a new

Customer Question

i have citroen zsara picasso diesel i was installing a new radio it was plugged in working not pushed back into recess i tapped 12v supply for it from purple wire used by oem radio multimeter confirmed 12v -engine was running started to put working radio into dashboard hole it stopped no display - checked 12v tap -12v still present turned engine off new message economy mode engine turns over will not start message also- immobiliser failure .lots of electrics not working- no headlights ,no heater fan, no wipers. checked top fuses in fuse tray rhs under bonnet all ok removed fuse tray cables lifted up and checked maxi fuses with dvm all ok. also key no longer operates central locking left battery on charge. it is under front seat dont know how to get immobiliser message up again says economy mode and engin still same turns oner missing elecrics and none starter .
Submitted: 1 year ago.
Category: UK Car
Customer: replied 1 year ago.
found second box under bonnet large fuses and relays all fuses ok . removed and checked all internal fuses to rhs of steering wheel all ok
Expert:  Peter Zavarelli replied 1 year ago.

Hi my name is ***** ***** I will be happy to assist with this today.In some cases I may need more info to assist better.I apologize for any delay.

Did the vehicle start and run when the radio was plugged in/hooked up but not pushed into its recess?

Let me know so we can continue,thanks Pete

Customer: replied 1 year ago.
it ran engine was running then i slid radio into recess power to radio disappeared thin red wire not used by radio may have grounded radio stopped i turned ignition off when i removed radio and turned ignition on all faults occured only just found poor insulation on thin red wire used by citroeen radio but not used by replacement radio
Customer: replied 1 year ago.
sorry i am working at night are you around tomorrow
Expert:  Peter Zavarelli replied 1 year ago.

I will be here tomorrow from around 5 am Mountain time US until about this time again.

Double check and make sure all fuses are o.k. in all fuse panels as I am unsure on what this wire is for for sure that grounded out.

If all fuses are found to be o.k. you might try and disconnect the battery for about 5 minutes then reconnect it to reset the electronics and see if this corrects the issue as well.

If this does not work then you will need to have the fault codes read out/checked with a compatible scan tool to see what codes are set in all computers to help determine the cause of the issue here.It is possible a computer was fried or damaged when this wire shorted out.

If more help is needed, use the reply tab to continue our conversation. If no further assistance is needed, kindly rate my service,your 5 star rating is appreciated ( should be a link to click on here or above).You can rate at any time and we can continue to work on your question as this will not close out your question.Keep in mind in some cases it can be difficult to fully diagnose or help repair your vehicle without seeing it and I work on delivering the best possible answer from what I see to work with.

Thanks Pete