How JustAnswer Works:
  • Ask an Expert
    Experts are full of valuable knowledge and are ready to help with any question. Credentials confirmed by a Fortune 500 verification firm.
  • Get a Professional Answer
    Via email, text message, or notification as you wait on our site. Ask follow up questions if you need to.
  • 100% Satisfaction Guarantee
    Rate the answer you receive.
Ask Peter Zavarelli Your Own Question
Peter Zavarelli
Peter Zavarelli,
Category: UK Car
Satisfied Customers: 29116
Experience:  Technical Consultant at Just Answer
14928985
Type Your UK Car Question Here...
Peter Zavarelli is online now
A new question is answered every 9 seconds

The engine in my 2009 Prius is pulling when I'm waiting to

Customer Question

Hi. The engine in my 2009 Prius is pulling when I'm waiting to reverse out or when I'm in neutral. Could it be the air intake ? Is it serious ?
JA: How long has this been an issue? How many miles are on the car?
Customer: I only noticed it at the weekend. It's done about 70,000 miles
JA: Are you fixing your Prius yourself? What have you tried so far?
Customer: No. I rang the Toyota dealership here in London UK & they want to run a diagnostic for £140. Repairs are charged on top. I was outraged !
JA: Anything else you want the mechanic to know before I connect you?
Customer: I think that's everything. We are waiting to take the car in for 2 recalls
Submitted: 2 months ago.
Category: UK Car
Expert:  Peter Zavarelli replied 2 months ago.

Hi my name is ***** ***** I will be happy to assist with this today.In some cases I may need more info to assist better.I apologize for any delay.

Can you describe a little more on what is occuring with this fault here?

Has anything been checked, tested or replaced to try and locate or repair this fault here at all?

Let me know so we can continue,thanks Pete.

Customer: replied 2 months ago.
Hi PeteThe car seems to be revving a bit high when we are stationary either in gear or in neutral. I haven't had any checks done yet . I rang Toyota today to book it in & they want to charge me £140 just for the diagnostic so I thought I'd try to figure it out myself .
Expert:  Peter Zavarelli replied 2 months ago.

I apologize for the delay.

This sounds to be a fault with a vacuum leak possibly on the engine.I would have the engine checked over for any loose,disconnected or damaged hoses causing this fault here.If this is checked and found o.k. then you will have to have the fault codes checked/read out to see what codes are set in all computers.Once this is done any codes set then need to be diagnosed to then locate and repair this issue here.Unfortunately this would require further testing to help pinpoint this issue if no visual leaks are found.

It may be o.k. to drive for now until you can have it looked into but I recommend having it checked into as soon as possible especially if any driving issues come up.

If more help is needed, use the reply tab to continue our conversation. If no further assistance is needed, kindly rate my service,your 5 star rating is appreciated ( should be a link to click on here or above).You can rate at any time and we can continue to work on your question as this will not close out your question.Keep in mind in some cases it can be difficult to fully diagnose or help repair your vehicle without seeing it and I work on delivering the best possible answer from what I see to work with.

Thanks Pete