How JustAnswer Works:
  • Ask an Expert
    Experts are full of valuable knowledge and are ready to help with any question. Credentials confirmed by a Fortune 500 verification firm.
  • Get a Professional Answer
    Via email, text message, or notification as you wait on our site.
    Ask follow up questions if you need to.
  • 100% Satisfaction Guarantee
    Rate the answer you receive.
Ask Ryan Schott Your Own Question
Ryan Schott
Ryan Schott,
Category: UK Car
Satisfied Customers: 83
Experience:  technician at Demarois Buick Gmc
77508644
Type Your UK Car Question Here...
Ryan Schott is online now
A new question is answered every 9 seconds

I've got an 2003 Tahoe 5.3 AWD. The front AC doesn't

Customer Question

Hi, I've got an 2003 Tahoe 5.3 AWD. The front AC doesn't come on unless the temperature is at least 66F but not always. So far I've replaced the compressor, both sensors body control module and control unit. Always the same problem. Had a workshop hook it up to a tech2 and then it is possible to manually activate the ac and it works fine until you turn off the car.
JA: Good to know. The mechanics have tons of experience dealing with this sort of thing. How old is your transmission?
Customer: since 2003
JA: Ok. We'll get you to one of the go-to transmission guys. Other than the problems you mentioned, how has the car been running?
Customer: fine
JA: Noted. I'll pass this info along to the mechanic so that he can get you a quick fix. Anything else I can tell the Chevy Mechanic before I connect you two?
Customer: Similar problem with the rear ac, I can control the fan speed but nothing else.
JA: Got it. Let's get this figured out. I'm sending you to a secure page on JustAnswer so you can place the $5 fully refundable deposit now. While you're filling out that form, I'll tell the Chevy Mechanic about your situation and connect you two. You'll be on the road in no time.
Submitted: 1 year ago.
Category: UK Car
Expert:  Ryan Schott replied 1 year ago.
So the compressor clutch does not engage or it just doesn't blow cold?
Customer: replied 1 year ago.
It doesn't engage. Already had the system charged and recharged twice.
Expert:  Ryan Schott replied 1 year ago.
which sensors did you replace?
Expert:  Ryan Schott replied 1 year ago.
here is the schematic, i assume you replaced the pressure and low pressure sensors, or did you put temp sensors in the dash? If it was commanded on with a tech 2 we know the circuit is intact from the pcm to relay to clutch so our issue is on the other side, if the low pressure switch is new we should test its ground first, do you have a test light or a multi meter?
Customer: replied 1 year ago.
I've replaced both pressure sensors. I have a multimeter and tech 2 to my disposal.
Expert:  Ryan Schott replied 1 year ago.
disconnect the low pressure sensor, the one on the accumulator on the pass side of engine compt, and ohm the black wire to ground.
Customer: replied 1 year ago.
I'm getting 0.10-0.15 at the 20k ohm setting
Expert:  Ryan Schott replied 1 year ago.
way too much resistance, run a ground jumper from that to the negative battery and see if your ac works.
Expert:  Ryan Schott replied 1 year ago.
plug it in and backprobe in a jumper that is.
Customer: replied 1 year ago.
No nothing happens
Customer: replied 1 year ago.
Same results
Customer: replied 1 year ago.
Tried back probing while connected with the multi meter and got 0.65 if that helps
Customer: replied 1 year ago.
But with the negative jumper connected to it it reads -0.90
Expert:  Ryan Schott replied 1 year ago.
what does it read disconnected key off in the 200 ohm range
Customer: replied 1 year ago.
2.5
Expert:  Ryan Schott replied 1 year ago.
okay that's way better .15 in 20k range is a lot more. next we need to ohm from the dark blue wire to the hvac control module, one sec and ill get a connector view for you
Expert:  Ryan Schott replied 1 year ago.
ohm to pin a12 in the 200 ohm range, will need less than 5
Customer: replied 1 year ago.
It reads -3.2
Customer: replied 1 year ago.
Sorry, 1.0 when key of and all electrics off.
Expert:  Ryan Schott replied 1 year ago.
plug back in and go in with your tech 2 and read pcm data, data2, look at ac request signal and see if it switches when you command it on or off.
Customer: replied 1 year ago.
When I go into body->HVAC->data display->input/output the A/C switch says off, on when pressed.
A/C permission withheld
Outside temp.raw 55F
Outside temp filte 25F
Pressure cycle switch normalA/C clutch won't engage unless I turn ax permission from withheld to granted.
Hope this helps.
Expert:  Ryan Schott replied 1 year ago.
in the PCM data list what does the high side pressure read?
Customer: replied 1 year ago.
74psi
Customer: replied 1 year ago.
And a/c request signal says no even when I press the snowflake button in dash
Expert:  Ryan Schott replied 1 year ago.
what does the pcm ambient air temp read.
Customer: replied 1 year ago.
IAT 80F
Customer: replied 1 year ago.
That's not what you are looking for, trying to find where they show ambient temp
Customer: replied 1 year ago.
But I did find A/C request and commanded it on and it works fine
Customer: replied 1 year ago.
Ok can't find ambient temp, only iat now 91F outside raw 59F and outside filter 25F. But my mirror says 50F
Expert:  Ryan Schott replied 1 year ago.
just a minute I haven't hooked up to an 03 in a while let me look. I can't spot it ,but the temp in your mirror should be it. All signs point to a hvac controller but you already replaced it so I'll have you try some odd things now. unplug that low pressure switch again and jump the dark blue wire straight to the negative battery post while its unplugged and try it, if not then remove the ambient temp sensor and cycle the ignition to see if it drops out or maxes out, then jump it and see if it changes, may need to cycle ignition. the temp sensor can be accessed below the turn signal.
Customer: replied 1 year ago.
Ok, no change when jumping the dark blue wire. Unplugged temp switch and temp in mirror maxed @99 and shortly went to 97. Still no A/C but idle is a little rougher
Customer: replied 1 year ago.
Jumped the temperature switch and no change in temp or ac
Expert:  Ryan Schott replied 1 year ago.
I'm going to reopen the question because i don't want to tell you to replace parts that you already did but i'm going to keep looking and see if i am missing something. Wait to respond so all experts can review your question.