How JustAnswer Works:
  • Ask an Expert
    Experts are full of valuable knowledge and are ready to help with any question. Credentials confirmed by a Fortune 500 verification firm.
  • Get a Professional Answer
    Via email, text message, or notification as you wait on our site.
    Ask follow up questions if you need to.
  • 100% Satisfaction Guarantee
    Rate the answer you receive.
Ask Matt Your Own Question
Matt
Matt, Mechanical Engineer
Category: UK Car
Satisfied Customers: 21708
Experience:  BEng hons Mech engineering, in auto industry 22 years
12772297
Type Your UK Car Question Here...
Matt is online now
A new question is answered every 9 seconds

Matt It is me again, If you remember my car problem:

Customer Question

Hi Matt It is me again, If you remember my car problem: TRANSMITION HOT - IDLE ENGINE message on the dash board. I have done all what you had suggested up to change the water pump & all the belts + thermostat And still have after 30 mn of drive, it is
happening again. What should I do?
Submitted: 2 years ago.
Category: UK Car
Expert:  Matt replied 2 years ago.
hello
OK the next thing to check is if the engine really is getting hot and we're not being led astray by a faulty sensor
if you use a thermal probe of some sort like this:
http://www.ebay.co.uk/itm/like/350828169514?limghlpsr=true&hlpv=2&ops=true&viphx=1&hlpht=true&lpid=108&chn=ps&device=c&rlsatarget=&adtype=pla&crdt=0&ff3=1&ff11=ICEP3.0.0-L&ff12=67&ff13=80&ff14=108&ff19=0
and point it at the exit pipe on the cylinder head for the radiator hose
it should read about 90°C
Customer: replied 2 years ago.
Hi MattI have replace the following part 2 month ago: Coolant Temperature Sensor / Part # *****
Also today engine temperature have been checked: 90....92
Same for transmition Temperature
Is there is other sensor to check or replace?
Expert:  Matt replied 2 years ago.
Hello
thats the only sensor but it could be a wiring fault thats offsetting the signal and creating the problem
so I'd still say to check the actual temperature as the next step
Customer: replied 2 years ago.
HI MattI confirm after checking the temperature is ok: 90 to 92 degrees no more.
What's next?
Expert:  Matt replied 2 years ago.
Hello
OK I'd next check the level of the oil inside the transmisson check its level with the gearbox warm and just after you've moved the selector through all the positions leaving it for a few seconds in each one and then back to park.
You can top up the box through the dipstick tube if required and make sure you use the correct oil for your car as the fluids are not all the same. Some manufacturers recommended a change of the type of fluid - Speak to the local dealer and parts dept - they will advise you on the updated fluid to use..
Customer: replied 2 years ago.
Don't you want to check if any electric wire is damage?Should I check the Gear Oil when engine on?
Expert:  Matt replied 2 years ago.
Hello
checking all the electrical connections of the gearbox is a good idea , remove each connector in turn and spray with contact cleaner. Check that the wiring to the gearbox is in good condition with no chafing or frayed wire
and you check the oil level with the engine warm but turned off
Customer: replied 2 years ago.
HI Matt,1- I have check oil level as you request - All ok!
By the way - must be DEXON VI?2- Engine Temperature: 90 Degres
Gear Temperature: 108 DegresProblem still existing.But funny part is that summer started here and I turn the AC on.
The problme still exisiting but it much more time to happen, maybe after*****What is next?
Expert:  Matt replied 2 years ago.
Hello
OK in that case its sounding like that the transmisson temp sensor need replacing
sorry to say that this is fairly invvolved as the sump has to come off and then locate the sensor on the valve block
Customer: replied 2 years ago.
I have replace the following part 2 month ago: Coolant Temperature Sensor / Part # *****
Is that the one you are talking about?
Expert:  Matt replied 2 years ago.
Hello
no
the transmisson oil temperature sensor thats lcated inside the transmisson is the one I'm referring to
Expert:  Matt replied 2 years ago.
Hi
do you still need help?
Customer: replied 2 years ago.
HI MATTAS PER NOW WE DID NOT SOLVE THE PROBLEMDO YOU THE PART NUMBER OF THIS SENSOR?
Expert:  Matt replied 2 years ago.
Hello
can you remind me of the vehuicle make and model and year?
Customer: replied 2 years ago.
BUICK ENCLAVE CX 2009