How JustAnswer Works:
  • Ask an Expert
    Experts are full of valuable knowledge and are ready to help with any question. Credentials confirmed by a Fortune 500 verification firm.
  • Get a Professional Answer
    Via email, text message, or notification as you wait on our site.
    Ask follow up questions if you need to.
  • 100% Satisfaction Guarantee
    Rate the answer you receive.
Ask Kelly Your Own Question
Kelly
Kelly, Appliance Technician
Category: UK Appliance
Satisfied Customers: 22244
Experience:  Highly accurate diagnostician with over 30 years experience!
11418111
Type Your UK Appliance Question Here...
Kelly is online now
A new question is answered every 9 seconds

I have a Miele G977 Plus Turbothermic and past few

Customer Question

I have a Miele G977 Plus Turbothermic and for the past few weeks the dishes are coming out not much cleaner than they went in.
I have taken out and cleaned the filter, added salt, run a cleaning programme and nothing has helped. When the programme has finished there's a sort of white froth over the floor. I usually run on standard but have tried other programmes and they're all the same.
What can I do to fix this please?
Submitted: 2 years ago.
Category: UK Appliance
Expert:  Kelly replied 2 years ago.
Hi, my name is ***** ***** I look forward to helping you! The froth is likely a build up of suds from using too much detergent. Pour a small amount of vegetable oil in the tub and start a rinse cycle. Once it has stopped, dump 1 liter of white distilled vinegar in the tub and run a complete cycle. That should remove and suds. Then, use a small amount of detergent on the next load and see how the results are.
Customer: replied 2 years ago.
Hi Kelly, thanks for your reply. However, this wasn't the problem. I use dishwasher tabs which prevent over doing the soaping thing and had run it through a cleaning cycle with the proper cleaning stuff three times in a week!I spent a lot of time at the weekend trying to figure out what could be wrong and having opened and shut the door a dozen times whilst it was running, I realised that the middle water sprayer wasn't moving more than a fraction. I took this out and then found that several of the spray holes were blocked. After cleaning this out (with a toothpick) and rinsing it through a few times, it's now working perfectly!
Customer: replied 2 years ago.
I've just realised that you have now taken two payments from my Barclaycard, one of £3 and another for £19. I would be grateful for a refund of the £19 please as I ended up solving my own problem.I'm sorry I couldn't get back to you as soon as you replied to me, but I have been away with no computer access.Thank you.
Expert:  Kelly replied 2 years ago.
I am glad you got it going. I don't have access to anything other than this thread, so for account issues you will need to contact customer service. The link below will take you to them. CLICK HERE
Customer: replied 2 years ago.
Thanks Kelly, I've done that.. and thanks for trying to help.
Expert:  Kelly replied 2 years ago.
Thank you, ***** *****!