How JustAnswer Works:
  • Ask an Expert
    Experts are full of valuable knowledge and are ready to help with any question. Credentials confirmed by a Fortune 500 verification firm.
  • Get a Professional Answer
    Via email, text message, or notification as you wait on our site. Ask follow up questions if you need to.
  • 100% Satisfaction Guarantee
    Rate the answer you receive.
Ask Anthony_Infotech Your Own Question
Anthony_Infotech
Anthony_Infotech, Technician
Category: TV
Satisfied Customers: 14891
Experience:  20+ years experience TV expert (field and bench) 9 approved qualifications in TV-ELECTRONICS
18621325
Type Your TV Question Here...
Anthony_Infotech is online now
A new question is answered every 9 seconds

I have a Panasonic TH-42PX80U with a 10 blinks light code.

Customer Question

Hi, I have a Panasonic TH-42PX80U with a 10 blinks light code. The Service Manual guided me to replace the Power Supply board, I ordered a used one on eBay and replaced it but the TV continues showing the same 10 blinks code. Now I don't know if the purchased part became damaged or if diagnose was wrong. How can I be shure of what is going on? Thanks.
JA: What's the model number of your TV? How old is it?
Customer: Panasonic TH-42PX80U, it's more than 4 years old.
JA: Does the TV menu work? Do you have the same problem on all sources/inputs?
Customer: No
JA: How long has this been an issue? What happened right before this popped up?
Customer: Nothing
JA: Is there anything else important you think the expert should know?
Customer: No
Submitted: 4 months ago.
Category: TV
Expert:  Anthony_Infotech replied 4 months ago.

Hello
Welcome
I am sorry you are having trouble here,I am presently reviewing your question be with you very soon.

Anthony

Expert:  Anthony_Infotech replied 4 months ago.

For a 10 blink code there are at least 4 boards that could cause it, there is a procedure of checks to go through as a guide, following those checks a decision is made on the board to order, if you can use a multi-meter (volt-ohm meter) I may be able to help you with this? I am assuming you still have the 10 blink code and no different issue?

Customer: replied 4 months ago.
the 10 blink code is still the issue, and I am able to use a multimeter
Expert:  Anthony_Infotech replied 4 months ago.

OK please let me know this info>>

Does the set go to 10 blinks IMMEDIATELY when you plug the set into wall-power OR do you have to switch the set ON with the remote THEN it blinks 10?

Customer: replied 4 months ago.
When I plug it to the wall and some click sounds comes from the power board. Then I try to power on the TV (with remote control or tv itself) and the 10 blinks code is showed until I disconnect from the wall.
Expert:  Anthony_Infotech replied 4 months ago.

So its not going immediately into a 10 blink code you have to switch it on OK give me 5 mins

Expert:  Anthony_Infotech replied 4 months ago.

Unplug the TV from wallpower disconnect SC2 and SC 20 on the SC scan board on the left

Expert:  Anthony_Infotech replied 4 months ago.

Replug back in, does it blink 10 or not please

Customer: replied 4 months ago.
Ok. SC2 and SC20 on the SC board disconnected and tested replugging back TV. Same 10 blink code.
Expert:  Anthony_Infotech replied 4 months ago.

So you disconnected those plugs on the SC board and plugged set back into the wall still 10 blinks, You need to replace the SC board that is the board you took those plugs out of, get the part-nuber fro the board found on the board itself and go to www.shopjimmy.com for a replacement using partnumber only

Expert:  Anthony_Infotech replied 4 months ago.

Please could you rate the answer positively with the rating bar of stars at the top of the page, rating me positively enables me to receive payment from the site thank you, ***** ***** question is open for 30 days

Many Thanks

Anthony

Customer: replied 4 months ago.
Anthony, what is the explanation for that, now that 10 blinks continues when SC board is isolated?
Expert:  Anthony_Infotech replied 4 months ago.

Let me go over this again, the set only goes to 10 blinks when you switch it on with the remote (most important as there are 2 scenarios for 10 blinks) then you disconnected those plugs on the SC board and replugged set back in still 10 blinks confirms SC board failure this is the very first check (no need for measurements) in the procedure to find out whih of the 4 boards is causing the issue, I will in a minute upload to you the technicians data for that, if you make mistakes in what I have indicated then this all goes wrong and is very unforgiving

Expert:  Anthony_Infotech replied 4 months ago.

Sorry I have been looking at the wrong data for this be right with you, there are two diff chassis hold on

Customer: replied 4 months ago.
I can upload you a picture of TV if you need it.
Expert:  Anthony_Infotech replied 4 months ago.

OK the next checks involve using a jumper but first yes upload a photo and I will have a good look at the set

Expert:  Anthony_Infotech replied 4 months ago.

Please also refit the original powerboard

Customer: replied 4 months ago.
Here is the picture, if you need a more detailed one please let me know
Expert:  Anthony_Infotech replied 4 months ago.

I am having site issues will be with you when this clears up

Customer: replied 4 months ago.
Hello
Expert:  Anthony_Infotech replied 4 months ago.

OK sorry about delays one was a site issue the other was I managed to get you the procedure for this issue

https://snag.gy/HoAB4R.jpg

Please click the link above follow the guide if you have problems let me know

Anthony

Customer: replied 4 months ago.
Followed both procedures. In the first one connector SS33 does not exist so I've followed procedure with CN SS23 that connects to C2 board, got the jumper from SS34 and placed on pins 8 and 10 of P12. The result was NO because the 10 blink code continued.So I went to second procedure: replaced all connectors back and measured Vsus and Vda. Both voltajes started at near 56 Volts and suddenly dropped down.
Customer: replied 4 months ago.
Hello,
Customer: replied 4 months ago.
Hello, is anyone there?
Customer: replied 4 months ago.
Gentlemen I'm very disappointed. It's been almost a week since Anthony referred me to a new Technician and nobody have answered. What do I need to do then?
Customer: replied 4 months ago.
Hello, anybody there!!!