How JustAnswer Works:
  • Ask an Expert
    Experts are full of valuable knowledge and are ready to help with any question. Credentials confirmed by a Fortune 500 verification firm.
  • Get a Professional Answer
    Via email, text message, or notification as you wait on our site. Ask follow up questions if you need to.
  • 100% Satisfaction Guarantee
    Rate the answer you receive.
Ask Jack Your Own Question
Jack
Jack, Technician
Category: TV
Satisfied Customers: 9915
Experience:  40 years experience as audio,video repair and installation tech
39158752
Type Your TV Question Here...
Jack is online now
A new question is answered every 9 seconds

I NEED THE FIRM WARE FOR A 46" KOGAN LED THAT HAS JUST HAD A

Customer Question

I NEED THE FIRM WARE FOR A 46" KOGAN LED THAT HAS JUST HAD A NEW MOTHERBOARD FITTED
JA: What's the model number of your TV? How old is it?
Customer: KALED463D1A
JA: Does the TV menu work? Do you have the same problem on all sources/inputs?
Customer: SAME MY NEIGHBOUR GAVE IT TO ME AS HE COULDNT FIND A WAY TO INSTALL THE FIRMWARE HOWEVER HE DIDNT GIVE ME THE FIRMWARE IF HE HAD IT \
JA: How long has this been an issue? What happened right before this popped up?
Customer: PIXEL LINES IN THE SCREEN NOW IT TURNS ON BUT JUST A BLACK SCREEN
JA: Anything else you want the TV expert to know before I connect you?
Customer: not really just where I can get the firmware
Submitted: 12 months ago.
Category: TV
Expert:  Jack replied 12 months ago.

Hi , I`m Jack

I`ll have a couple questions that may save you from wasting time on this .

I don't know who told your friend that this was a firmware issue but it sure doesn`t sound like it to me

You said this started with lines on the screen and now it is completely out ??

Customer: replied 12 months ago.
he has bought a new main board and fitted it
Expert:  Jack replied 12 months ago.

Those lines , were they horizontal or vertical ?

Customer: replied 12 months ago.
I have just turned it on again and I get a lit screen with no lines but that is it
Expert:  Jack replied 12 months ago.

So you don't know if they were vertical or horizontal ?

Customer: replied 12 months ago.
No mate he didn't mention
Expert:  Jack replied 12 months ago.

In any case your friend bought that main board for nothing and a firmware certainly wont do anything

What you have at best is a defective t-con board if the lines were vertical and a bad LCD panel if horizontal , again , NOT a main board or firmware

Customer: replied 12 months ago.
I have tried different buttons but the screen just shuts down again with no lines now.
What do I need to do to get this fixed or should I just strip the usable parts off it
Customer: replied 12 months ago.
Which of the three boards is the T-Con board and is it cost effective to replace it
Expert:  Jack replied 12 months ago.

Your best bet if you want to repair it would be to find a t-con board , THAT is the problem you have now and possibly the same guy that sold you that main board have one or use the part number on it to serach ebay for example .

Otherwise you would be better off turning it to target practice

The t-con is connected directly into the panel and usually sits in the upper center under a metal shield .

Good luck with that

Let me know if you have other questions and if not for now then please do not forget to rate by clicking on the star icons at the top of your page, then click on Submit so i get paid for my time helping you .
Also note that it will not close this post , you can come back here at any time if you need further info or help .
Thank you

Customer: replied 12 months ago.
The board you describe is the covered one in the centre with the connections to the panel. Please excuse my inexperience but that was the board he pointed out that he had replaced.
Expert:  Jack replied 12 months ago.

In that case you have a defective panel by the look of it , I mean those lines were not a good sign and even though they seem to have gone away , I`m sure they didn`t fix themselves .

One thing though , double check the connections by pulling them out and back in or evn try the old board back to see what it does ?

Customer: replied 12 months ago.
Ok then I will give that a go
So the firm ware is definitely not the problem, he seemed so sure that was it and mentioned that it had to be flashed onto the screen or something like that .
Expert:  Jack replied 12 months ago.

firmware are for main boards and now you are talking t-con !!

Expert:  Jack replied 12 months ago.

Any questions on this ?
Remember that you can come back here at any time after rating (no additional charges) if you have other questions related to that

Customer: replied 12 months ago.
Ok Jack,
Look thanks for your help I think the screen is one step closer to being an anchor
Expert:  Jack replied 12 months ago.

Much welcome and please do not forget to rate with the stars at the top of your page (and SUBMIT) so i can get compensated for my time helping you.

Customer: replied 12 months ago.
No worries have a good one
Expert:  Jack replied 12 months ago.

Thank you and Cheers