How JustAnswer Works:
  • Ask an Expert
    Experts are full of valuable knowledge and are ready to help with any question. Credentials confirmed by a Fortune 500 verification firm.
  • Get a Professional Answer
    Via email, text message, or notification as you wait on our site.
    Ask follow up questions if you need to.
  • 100% Satisfaction Guarantee
    Rate the answer you receive.
Ask Aric Your Own Question
Aric
Aric, Technician
Category: TV
Satisfied Customers: 44491
Experience:  15+ years in the field. Owner of AV Installation, OEM and Repair company
24739752
Type Your TV Question Here...
Aric is online now
A new question is answered every 9 seconds

My Sony LCD TV, Model #KDF-E42A10, made a loud pop sound and

Customer Question

My Sony LCD TV, Model #KDF-E42A10, made a loud pop sound and everything went blank. No picture, no sound. The power indicator green LED blinked for about a minute like it does when the unit has been turned off and then it went off. I waited a few minutes to make sure everything had a chance to cool down and reset. Then I powered it back up. Same thing with the blinking LED but no picture, no soune and then it shut off again. I know these TV's are image projected from a HID lamp source and they can burn out. Do you suspect that is the problem and what would be a Sony part number for the lamp and estimated cost?
Submitted: 5 years ago.
Category: TV
Expert:  Aric replied 5 years ago.

How long have you had the set for and has any work ever been done on it?

 

Does the Green LED blink continuously, or in a pattern (such as 3 blinks, pause, 3 blinks, pause, etc.)?

Customer: replied 5 years ago.

Purchased on 2006 or 2007 I think.

 

Green LED just blinks continuously I think. I didn't notice any sort of pattern.

Expert:  Aric replied 5 years ago.

Have you ever replaced the Lamp?

 

Also, when you press power, do the fans come on, do you hear any clicking sounds, or buzz coming from the set?

Expert:  Aric replied 5 years ago.
I need to step away for 10 minutes, I will be back with you at that point.
Customer: replied 5 years ago.

No. The lamp has never been replaced. Yes, the fan comes on and runs during the time the LED is blinking and then all powers off. No other buzzing, clicking, or smells are noticed.

 

That's fine. I will be waiting.

Expert:  Aric replied 5 years ago.

Sorry for the delay. The problem indeed points to a faulty lamp on this set. Also, considering the lamps commonly only last between 3-5 years or so, you are well beyond that point and this would lead to the symptoms you're having. You need to replace the lamp. The link to the lamp for your set is below:

 

http://www.amazon.com/Sony-KDF-E50A10-KDFE50A10-Housing-XL2400/dp/B002Y0SV28

 

If this answers your question, please click "Accept", as it is the only way we Experts get paid for our knowledge on the site. Tips and Bonuses are welcome and appreciated!!

Aric and 2 other TV Specialists are ready to help you
Customer: replied 5 years ago.

Aric,

Thanks for your research and response. One question though. I notice the link above references a Sony-KDF-E50A10-Housing and lamp. Is this correct also for my Sony KDF-E42A10 set?

Expert:  Aric replied 5 years ago.

Let me doublecheck that, it came up under the search for yours. I will be right back.

 

I'm not sure if the one above is correct, it may be the same part number as the one below. I know the one below is the proper lamp for your set though:

 

http://www.allprojectorlamps.com/product.asp?itemid=42659&gclid=COnKraGBn68CFQjd4AodzHgKZw

 

If this answers your question, please click "Accept", as it is the only way we Experts get paid for our knowledge on the site. Tips and Bonuses are welcome and appreciated!!

Customer: replied 5 years ago.

Aric,

I did go to one of the links brought up for Amazon.com from your link above and I did find a listing that shows it is indeed the same lamp for both models above and more.

Thaks again for your assistance.

Expert:  Aric replied 5 years ago.
Okay good to hear. You're welcome.