How JustAnswer Works:
  • Ask an Expert
    Experts are full of valuable knowledge and are ready to help with any question. Credentials confirmed by a Fortune 500 verification firm.
  • Get a Professional Answer
    Via email, text message, or notification as you wait on our site. Ask follow up questions if you need to.
  • 100% Satisfaction Guarantee
    Rate the answer you receive.
Ask James Your Own Question
James
James, Technician
Category: TV
Satisfied Customers: 2205
Experience:  AV Service Engineer (4 Years)
24944807
Type Your TV Question Here...
James is online now
A new question is answered every 9 seconds

I have a Vizio L37 HDTV thats about 4 years old (bought it

Customer Question

I have a Vizio L37 HDTV that's about 4 years old (bought it from Sams), and it won't turn on. The yellow light is on though when I have it plugged in! If I press the power button, either from the remote or on the TV itself, nothing happens. Ive tried unplugging it, plugging it back in, holding the power button for 30 seconds and nothing happens. It's obviously getting power because the light is on. I don't want to just throw it away.. Any ideas? Thanks!
Submitted: 8 years ago.
Category: TV
Expert:  James replied 8 years ago.
Hi There,

Chances are there is a problem with the power supply board in the TV.

The only thing I would suggest is to leave it unplugged for 24hrs then try turning it on again. This has the effect of discharging all of the capacitors within the unit, and effectively soft rebooting the unit.

What to do next depends entirely on whether you want to try and fix it at home, and have a good multimeter and are comfortable with soldering. If you are then let me know and I'll tell you what to look for. Otherwise you'd be best off taking it to a local electronics repair shop.

Typically the some of the capacitors on the board can go faulty.

Alternatively, if you have had it for less than a year, take it back to the place you bought it from and have them deal with it.

Hope this helps

James
Customer: replied 8 years ago.
Thanks! I figured it was a power supply issue after some of the research I did.. Im not sure it's worth the effort of soldering and all that to get it back to working..its about 4 years old now.. As for the unplugging and resetting thing, Ive had it unplugged for a few weeks now, and I just went back in and replugged it back in, the green/yellow light came on, but the TV won't power on.. Thanks again!
Expert:  James replied 8 years ago.
Hi There,

The best thing to do in that case is to take the case of the back of the TV, and find the PSU board, it will be the board where the power cable from the wall connects to.

Have a look at the board and check all of the capacitors, they should have a completely flat top and should not be leaking any liquid. I've attached a picture below of a bulging capacitor which would need to be swapped out.

graphic

If you do find some then let me know, as it means my diagnosis was correct, you can then either buy a complete replacement board, or swap the capacitors out yourself. Make sure the replacements are of the same capacitance, if you can fit them in there, use a slightly higher voltage as they will last a little longer.

Hope this helps

James