Transmissions

Have Transmission Questions? Ask a Mechanic for Answers ASAP

Ask an Expert,
Get an Answer ASAP!

This answer was rated:

My 4wd quite working on my 1998 Chevy Blazer - the 3 push…

My 4wd quite working on...
My 4wd quite working on my 1998 Chevy Blazer - the 3 push buttons 2WD 4HI 4LO are not lite up. I have removed the battey and the battery tray and found the vacum pump. The cable that the diaphram actuator seems to move freely when I push pull with my fingers. With the engine running, the 3 buttons don't actuate the the diaphram and pull push the cable (nothing). I disconnected the vacum hose from the diaphram actuator and could not detect any suction at the end of the line with engine running. What should I look at next?
Show More
Show Less
Ask Your Own Transmissions Question
Answered in 2 hours by:
1/18/2018
Todd Audette
Todd Audette, A.S.E Certified Master Technician
Category: Transmissions
Satisfied Customers: 427
Experience: GM Transmission Technician
Verified

Hi my name is*****'m an A.S.E Certified Master Technician with 30 + yrs GM experience. I'm reviewing you question and would be happy to assist you.

Ask Your Own Transmissions Question

Please give me a little time to review and i will be back to you shortly

Ask Your Own Transmissions Question

If the lights on the switch aren't lighting up it may not have anything to do with the cable or the vacuum actuator it has more to do with the 4wd module.

Ask Your Own Transmissions Question
Customer reply replied 4 months ago
OK - I will do some more checking - might show something on diagnostics?
Customer reply replied 4 months ago
Or could it be a fuse? I am leaving now and will check in tomorrow - Thanks

Ok check fuses tomorrow and get back to me. I will tell you what to do next

Ask Your Own Transmissions Question
Customer reply replied 4 months ago
I don't see any burned fuses.

Behind the right side kick panel on the passenger side just forward of the door is where the module is located. Un plug it and check for any corroded wires...plug it back in and see if it starts to work

Ask Your Own Transmissions Question
Customer reply replied 4 months ago
OK -thanks for the diagram. I opened the panel - pulled the harness plug, No corrosion. plugged back in snug, started the vehicle. - No ***** *****ghts behind the 3 2/4 wd buttons. Could the module be bad?

Yes but i'll have you check 1 more thing first...Stand by

Ask Your Own Transmissions Question
Customer reply replied 4 months ago
OK

Was there only 1 plug on it

Ask Your Own Transmissions Question
Customer reply replied 4 months ago
1 BLUE PLUG
Customer reply replied 4 months ago
Just plugged in OBD tool - no error codes came up

Test for power on the orange wire

Ask Your Own Transmissions Question
Customer reply replied 4 months ago
OK will do

Make sure to test with the key in the on position

Ask Your Own Transmissions Question
Customer reply replied 4 months ago
I pulled the blue plug out, found the largest orange wire checked the female part of the blue plug, no power, checked the back side of the wire crimp inside the plug and poked through the wire insulation with a "light up tester" with the alligator clip grounded - no power. Ignition key was on and headlights were on - engine not running.
Customer reply replied 4 months ago
Was the plug supposed to be plugged into the module?

No I didn't need to be plugged in....How many wires on that connector?

Ask Your Own Transmissions Question
Customer reply replied 4 months ago
one moment -
Customer reply replied 4 months ago
25 wires
Customer reply replied 4 months ago
There were several orange wires - I tested the largest one

Check the ATC fuse at the underhood fuse box with a test light. Also check the 4wd fuse at the instrument panel fuse box with a test light....test both sides of the fuses with the key on

Ask Your Own Transmissions Question
Customer reply replied 4 months ago
ok - one moment
Customer reply replied 4 months ago
OK WITH KEY ON - ATC fuse terminals under hood fuse box = no power either side, 4WD fuse at location #15 on the instrument fuse panel per owners manual - no power on either terminal -both fuses appear to be OK and not burned

Give me a little while to investigate why you have no power to these fuses and I will get back to you

Ask Your Own Transmissions Question
Customer reply replied 4 months ago
OK thank you - in the meantime, I will look for loose connections that I can locate.

Yes do that

Ask Your Own Transmissions Question

Are you sure you had a good ground connection on the clip end of the test light

Ask Your Own Transmissions Question
Customer reply replied 4 months ago
I will double check with various ground locations unpainted
Clamp it to the negatve terminal on the battery that is the best spot. Verify your test light works by touching the positive side with the point end
Ask Your Own Transmissions Question
Customer reply replied 4 months ago
Yep - I use a long alligator clipped wire and extended the ground connection to the negative battery terminal and this time I get power at both the ATC fuse terminal and the 4wd terminal at the instrument panel. But still no power at the termination of the orange wire on the plug to the 4wd module inside the kick panel on the passenger side
Customer reply replied 4 months ago
Sorry for the mis fire
Customer reply replied 4 months ago
You were correct, I did not have a good ground
Customer reply replied 4 months ago
Question - when I tested the orange wire - the plug is unplugged from the 4wd module - does it need to be plugged in for that test?

No it does not have to be plugged in

Ask Your Own Transmissions Question

You said there were several orange wires....check all of them

Ask Your Own Transmissions Question
Customer reply replied 4 months ago
OK - will do
Customer reply replied 4 months ago
The big wire I first checked and called the "orange wire" is actually a large RED wire with no power
Their are 4 other orange wires - 2 medium size orange wires at the opposite end of the block ( side by side) and both have power. Then 2 very small orange wires in the mid section of the block and no power on those two
Customer reply replied 4 months ago
I guess I am a bit color blind - sorry for that
Customer reply replied 4 months ago
NAPA has a replacement module, 32 pin that looks like the right part, if that is what is needed. It will take me about and hour to go and get https://www.napaonline.com/en/p/NDP5980000
i think that is what needs to be replaced. Keep in my that rating this service will not close out the session and i will be available for further diagnosis and follow up questions you may have for me
Ask Your Own Transmissions Question
Customer reply replied 4 months ago
OK - I am on it. I will put it in and let you know. So far you have been helpful and have earned a tip. Will send you a note later today when I get it done. Thanks
Ok sounds good
Ask Your Own Transmissions Question
Customer reply replied 4 months ago
Hi Todd - I put the new 4wd module in and the ***** *****ghts don't light up at the 3 4wd buttons and don't actuate. I still have the vacum hose disconnected from the diaphram actuator and don't feel any suction at that end of the hose. What should I look at next?

Sorry to here that....based on our conversation i was thinking that may have been it..keep in mind that i'm not there testing things myself so this can be challenging to say the least. You wont have vacuum there until the transfer case has completed a shift in to 4hi or 4lo....I recommend you test every fuse in the truck with the test light....Key on. There is a vacuum switch on the top of the transfer case that supplies the vacuum to that actuator....That actuator engages the front axle but not the transfer case.

Ask Your Own Transmissions Question
Customer reply replied 4 months ago
OK - I understand - I will keep working on it. Thanks
Customer reply replied 4 months ago
Yep - I understand - I am going to check the vacum switch tomorrow. I have to pull off a protector plate to be able to get to it, but no big deal. I will check back with you later. I will try and see if it is in 4wd or not and see if the encoder motor is doing anything. I am sure you could fix it faster than me - I just wanted to give it a try. I can take it in to a mechanic - not an issue, just wanted to try my luck first.

Have you made any progress?

Todd Audette
Todd Audette, A.S.E Certified Master Technician
Category: Transmissions
Satisfied Customers: 427
Experience: GM Transmission Technician
Verified
Todd Audette and 87 other Transmissions Specialists are ready to help you
Ask your own question now
Customer reply replied 3 months ago
I replaced the module, transfer case switch, transfer case motor and push buttons on the dash and now it works. Thank you.

Great news. Glad to hear you got it fixed

Ask Your Own Transmissions Question
Was this answer helpful?
Ask Todd Audette Your Own Question
Todd Audette
Todd Audette
Todd Audette, A.S.E Certified Master Technician
Category: Transmissions
Satisfied Customers: 427
427 Satisfied Customers
Experience: GM Transmission Technician

Todd Audette is online now

A new question is answered every 9 seconds

How JustAnswer works:

  • Ask an ExpertExperts are full of valuable knowledge and are ready to help with any question. Credentials confirmed by a Fortune 500 verification firm.
  • Get a Professional AnswerVia email, text message, or notification as you wait on our site. Ask follow up questions if you need to.
  • 100% Satisfaction GuaranteeRate the answer you receive.

JustAnswer in the News:

Ask-a-doc Web sites: If you've got a quick question, you can try to get an answer from sites that say they have various specialists on hand to give quick answers... Justanswer.com.
JustAnswer.com...has seen a spike since October in legal questions from readers about layoffs, unemployment and severance.
Web sites like justanswer.com/legal
...leave nothing to chance.
Traffic on JustAnswer rose 14 percent...and had nearly 400,000 page views in 30 days...inquiries related to stress, high blood pressure, drinking and heart pain jumped 33 percent.
Tory Johnson, GMA Workplace Contributor, discusses work-from-home jobs, such as JustAnswer in which verified Experts answer people’s questions.
I will tell you that...the things you have to go through to be an Expert are quite rigorous.

What Customers are Saying:

I would (and have) recommend your site to others I was quite satisfied with the quality of the information received, the professional with whom I interacted, and the quick response time. Thanks, and be sure that I'll be back whenever I need a question answered in a hurry.

Stephanie PElm City, NC

used your service this weekend with "Trecers" help. thank you ,thank you, thank you. replaced an A/C fan motor. Local Auto Zone had part. $15.00 "tracer" fee and $40.00 for parts, I saved several hundreds of dollers at a shop. i will recommend you and use you in the future.

David L.Richmond, TX

9 dollars, 2 hours of my time, and I drove away. Your diagnosis was right on the mark. Thank you so much.

PhilMarysville, CA

Lurch. Thank you very much. I had real doubts about this website but your promptness of response, quick followup and to the point answer with picture was incredible.

CharlesWalnut Creek, CA

As a single woman, I really appreciate an excellent and affordable opinion.
Thank you Geordie, I will not hesitate to contact justanswer in the future!

SueCharleston, WV

Another great insight to what may be the problem. I will have my mechanic take a look at it tomorrow. Thanks again, Frank...you do indeed know your stuff.

JimCastleberry, FL

Wonderful service, prompt, efficient, and accurate. Couldn't have asked for more. I cannot thank you enough for your help.

Mary C.Freshfield, Liverpool, UK

< Previous | Next >

Meet the Experts:

Chris (aka- Moose)

Chris (aka- Moose)

Technician

1,788 satisfied customers

16 yrs. experience with auto, manual, & CVT drivelines

Tim&#039;s Auto Repair

Tim's Auto Repair

Mechanic

496 satisfied customers

I have been rebuilding automatic transmissions for 25 years

Gary

Gary

ASE Certified Technician

396 satisfied customers

25 years GM master tech

Mike Kelly

Mike Kelly

ASE Certified Technician

150 satisfied customers

17 years experience as an auto mechanic, foreign and domestic. 5 years running my own repair business.

Matt

Matt

Engineer

134 satisfied customers

Mechanical Engineer BEng Hons22 years experience in car engine industry, 10 years in formula 1

Dave Nova

Dave Nova

ASE Certified Tech

98 satisfied customers

ASE Master Certification. 25 yrs experience

John Mc

John Mc

Trans specialist

93 satisfied customers

Transmission dealer tech for over 19 years

< Previous | Next >

Related Transmissions Questions
My gears does not shift from 2nd to 3rd. 04. Milan. Trying
I had it checked they it is one of the sensor but I don't know wich one is bad… read more
HDGENE
HDGENE
Master Technician/Lead Technician
Associate Degree
2,835 satisfied customers
Changed starter and flywheel now it won't move at all did
Changed starter and flywheel now it won't move at all did before that … read more
Edward Clayton
Edward Clayton
Associate Degree
1,033 satisfied customers
The gear shifter is moving up and down but car will not go
The gear shifter is moving up and down but car will not go into gear neither is it going into gear on the dash. Drove it home earlier with no signs of problems. … read more
Todd M
Todd M
Owner
ASE Certification
1,764 satisfied customers
I have a 06 nissan altima it has reverse and 1st gear ....no
I have a 06 nissan altima it has reverse and 1st gear ....no 3rd and second nor drive....i disconnect the trans comp or a sensor on the trans and all runs great … read more
Chris (aka- Moose)
Chris (aka- Moose)
Technician
Vocational, Technical or Trade School
1,788 satisfied customers
Service 4wd light on in dash with po315 code tranfer case
service 4wd light on in dash with po315 code tranfer case code w snap- on scaner … read more
Tim&#039;s Auto Repair
Tim's Auto Repair
Mechanic
High School or GED
496 satisfied customers
I have an 0073 code and my Traverse shifts into the first 3
I have an 0073 code and my Traverse shifts into the first 3 gears, and that's it. When I push down on the gas my rpms goes up to 4, and the car won't shift into any other gear. … read more
Pete
Pete
Independent Auto Technician
Vocational, Technical or Trade Scho
138 satisfied customers
It shifts hard and at higher speeds it cuts out. 96 and yes.
Oil for stop leak and hard shifting just bought the vehicle … read more
Chris (aka- Moose)
Chris (aka- Moose)
Technician
Vocational, Technical or Trade School
1,788 satisfied customers
Car goes into reverse but wont go forward.plus 4 wheel seems
car goes into reverse but wont go forward.plus 4 wheel seems to be locked out … read more
Edward Clayton
Edward Clayton
Associate Degree
1,033 satisfied customers
The Transmission won't shift. Seems to be stuck in 3rd/4th.
The Transmission won't shift. Seems to be stuck in 3rd/4th. I have done some troubleshooting, but can't get any advice from local sources...... need insight and/or suggestions... … read more
vwtech0405
vwtech0405
VW Technician
Associate Degree
8,868 satisfied customers
2006 Ford Escape 91k miles. No movement in ANY gear. Park
Hi there! 2006 Ford Escape 91k miles. No movement in ANY gear. Park position does hold the car, but all forward gears and reverse gear, nothing happens; can't feel the transmission engage and the car … read more
Pete
Pete
Independent Auto Technician
Vocational, Technical or Trade Scho
138 satisfied customers
My car hesitates to accelerate unless I hit the gas to the
My car hesitates to accelerate unless I hit the gas to the floor, and it shifts hard. The wrench, airbag and gas light come on all at the same time & makes my mileage counter blank and gas counter bla… read more
Pete
Pete
Independent Auto Technician
Vocational, Technical or Trade Scho
138 satisfied customers
My 2016 kia sorento awd occasionally shifts hard at about 20
my 2016 kia sorento awd occasionally shifts hard at about 20 to 25mph and once it refused to shift up after being shifted down for 4 to 5 miles on a steep hill. after 10 miles or so, it returned to no… read more
Matt
Matt
Engineer
Bachelor's Degree
134 satisfied customers
2003 Ford Ranger Transfer Case needs replaced. No, took it
No, took it to a mechanic since it was leaking transmission fluid. Quoted me $2,100. Not sure if it is worth it, truck has 260,000 miles. … read more
kalamykid
kalamykid
Pactor automotive
Vocational, Technical or Trade Scho
97 satisfied customers
Engine shutting off as soon as I put it in drive. Automatic
engine shutting off as soon as I put it in drive JA: How many miles are on the car? Is it an automatic or a manual transmission? Customer: automatic transmission over 100,000 miles JA: What is the mod… read more
Eric
Eric
Retired
N/A
14,436 satisfied customers
Stop for red light the car is jerking wan to move forward.
stop for red light the car is jerking wan to move forward … read more
Chris (aka- Moose)
Chris (aka- Moose)
Technician
Vocational, Technical or Trade School
1,788 satisfied customers
Won't move forward, eng rpms won,t rev when in drive but
won't move forward, eng rpms won,t rev when in drive but revs in park … read more
Chris (aka- Moose)
Chris (aka- Moose)
Technician
Vocational, Technical or Trade School
1,788 satisfied customers
Just got a 2009 Chevy Malibu Hybrid. While driving home
Just got a 2009 Chevy Malibu Hybrid. While driving home there were messages for service hybrid, service esc, service traction, transmission shifting hard. Have found this description on the internet w… read more
Eric
Eric
Auto Technician
589 satisfied customers
I need to replace the cvt trans on my 2014 versa I found one
I need to replace the cvt trans on my 2014 versa I found one online from Chicago. I live in CAli. I haven't pulled a tranny in several years. Are these complicated? … read more
Chris (aka- Moose)
Chris (aka- Moose)
Technician
Vocational, Technical or Trade School
1,788 satisfied customers
Disclaimer: Information in questions, answers, and other posts on this site ("Posts") comes from individual users, not JustAnswer; JustAnswer is not responsible for Posts. Posts are for general information, are not intended to substitute for informed professional advice (medical, legal, veterinary, financial, etc.), or to establish a professional-client relationship. The site and services are provided "as is" with no warranty or representations by JustAnswer regarding the qualifications of Experts. To see what credentials have been verified by a third-party service, please click on the "Verified" symbol in some Experts' profiles. JustAnswer is not intended or designed for EMERGENCY questions which should be directed immediately by telephone or in-person to qualified professionals.

Disclaimer: Information in questions, answers, and other posts on this site ("Posts") comes from individual users, not JustAnswer; JustAnswer is not responsible for Posts. Posts are for general information, are not intended to substitute for informed professional advice (medical, legal, veterinary, financial, etc.), or to establish a professional-client relationship. The site and services are provided "as is" with no warranty or representations by JustAnswer regarding the qualifications of Experts. To see what credentials have been verified by a third-party service, please click on the "Verified" symbol in some Experts' profiles. JustAnswer is not intended or designed for EMERGENCY questions which should be directed immediately by telephone or in-person to qualified professionals.

Show MoreShow Less

Ask Your Question

x