How JustAnswer Works:
  • Ask an Expert
    Experts are full of valuable knowledge and are ready to help with any question. Credentials confirmed by a Fortune 500 verification firm.
  • Get a Professional Answer
    Via email, text message, or notification as you wait on our site.
    Ask follow up questions if you need to.
  • 100% Satisfaction Guarantee
    Rate the answer you receive.
Ask Chad Farhat Your Own Question
Chad Farhat
Chad Farhat, ASE Certified Technician A6 - Electrical / Electronic systems A7 Heating / Air conditioning systems
Category: Transmissions
Satisfied Customers: 3483
Experience:  Owner at Carolina Auto Service & Sales , 20 years Experience in Foreign & Domestic vehicle
45790705
Type Your Transmissions Question Here...
Chad Farhat is online now
A new question is answered every 9 seconds

99 ford f250 5.4, intermittent speedometer and hard shift

Customer Question

99 ford f250 5.4, intermittent speedometer and hard shift when it drops out
JA: How old is the transmission? Have you noticed any leaking?
Customer: no leaks whatsoever
JA: Are you fixing your F250 yourself? What have you tried so far?
Customer: i replaced the speed sensor on rear diff. but i believe there is 2 more on tranny
JA: Anything else you want the mechanic to know before I connect you?
Customer: help! haha
Submitted: 10 months ago.
Category: Transmissions
Expert:  Chad Farhat replied 10 months ago.

Hi, I'm Chad. Welcome to JustAnswer. I'm reviewing your question and I will be posting your reply ASAP.

Customer: replied 10 months ago.
thanks
Expert:  Chad Farhat replied 10 months ago.

You welcome

I sent a picture of the transmission showing the sensors, there is 3 trans in picture, depends which one you have

one which is the 4R100 has 2 sensor on transmission , output & input

and the other 2 just output sensors

1- output shaft sensor

2- input shaft sensor( depend which trans you have ,you might not have that ,check it )

3-rear diff sensor, you said you already replaced .

If you changed the diff sensor , make sure connector making good connection ,spray electrical contact cleaner and replaced the output * input shaft sensor

https://www.dropbox.com/s/hfn6hoxnqfp4n71/0.gif?dl=0

Let me know if you need anything else on it , just reply back here & we can continue.

if you are good , Please Kindly rate me.

Hope I was helpful to you

A 5 Star Positive Rating is Much Appreciated

This Post Will Stay Open for You To Come back and Ask me Any Follow Up Question You May have on this issue , even after you rate me

Thank You

Chad Farhat
ASE Certified Tedchnician

Customer: replied 10 months ago.
I'm going to replace the other 2 sensors as you stated. is there any other things that may cause this(besides a bad wire/short)?
Expert:  Chad Farhat replied 10 months ago.

yes i would change them first .

when inspecting all sensors connector , get a flash light and shine inside make no backed out pins are in that connector.

we find a lot of case of bend pins or backed out pins , if the sensor are function ans still having problems .

lastly if the problem still exist , then a continuity test is required on the sensors harness.

Good Luck

Chad

Customer: replied 10 months ago.
Thanks chad
Expert:  Chad Farhat replied 10 months ago.

You Welcome

Let me know if you need anything else on it , just reply back here & we can continue.

if you are good , Please Kindly rate me.

Hope I was helpful to you

A 5 Star Positive Rating is Much Apreciated

This Post Will Stay Open for You To Come back and Ask me Any Follow Up Question You May have on this issue , Even after you rate me

Thank You

Chad Farhat
ASE Certified Tedchnician