How JustAnswer Works:
  • Ask an Expert
    Experts are full of valuable knowledge and are ready to help with any question. Credentials confirmed by a Fortune 500 verification firm.
  • Get a Professional Answer
    Via email, text message, or notification as you wait on our site.
    Ask follow up questions if you need to.
  • 100% Satisfaction Guarantee
    Rate the answer you receive.
Ask Pete Your Own Question
Pete
Pete, Automotive Mechanic
Category: Transmissions
Satisfied Customers: 28191
Experience:  GM and Mercedes vehicle technician.17 years experience.
14928985
Type Your Transmissions Question Here...
Pete is online now
A new question is answered every 9 seconds

85 Toyota 4x4 p/u shifts hard from park to reverse...or

Customer Question

85 Toyota 4x4 p/u shifts hard from park to reverse...or neutral to drive or reverse...seems Iheard a bad air idle control could cause this?
Submitted: 2 years ago.
Category: Transmissions
Customer: replied 2 years ago.
I have no idea if all of the idle controls and adjustments are correct or where to start setting them to be sure they are correctly adjusted
Expert:  Pete replied 2 years ago.
My name is ***** ***** I am a professional here at Just Answer. I noticed that your question was not getting a response and thought I would see if you still need help with this.I apologize for the delay and I hope I can still assist you with this here.
If your engine is idling high with this issue here this can sometimes be caused by a vacuum leak on the engine itself.If you have not had the engine checked over for any vacuum leaks this needs done and if one is found it will need repaired.In some cases the leak has to be checked with a smoke machine injecting smoke into the intake to locate any hard to see leaks.
Thanks Pete
Customer: replied 2 years ago.
hi Pete...one thing I've noticed is when I press on the gas pedal there is poor response slow to increase idle [this is sitting with vehicle in Park] plus, when I remove foot from accelerator pedal it sometimes doesn't return to normal idle and I have to kinda 'romp' pedal again to get it to idle down, like the linkage isn't returning all the way back to where it should be for normal idle [stiff or something]...I say this because I know if idling too high it will make transmission shift hard, but if this was a vacuum leak, it would be idling high all of the time and I would not be able to make it idle down to normal, wouldn't it?...this truck is a work in progress for my son, and not road worthy as of yet...all of the work I have to do...
Expert:  Pete replied 2 years ago.
I would inspect the linkage at the carb./throttle body and see if any issues are found with it causing this fault here.I have seen some vacuum leaks that start to occur off idle or at idle in some cases and cause this and I have seen the idle air control motor fail on some models and cause this as well needing replaced.
Thanks Pete
Customer: replied 2 years ago.
on this truck when I press on gas pedal and let off, what returns the accelerator linkage back to 'home position' ?...it has a cable on top of linkage and a cable below linkage...which one does what, if you don't mind me asking...kinda looks like one might work linkage one way to increase idle and the other might work [return] linkage back to 'home position'...
Expert:  Pete replied 2 years ago.
Unfortunately my info is limited on this model here so I don't have this info.I will have to open this question up for others here to see if they can assist further on this as someone else here may have more info on what to check or do with this issue.I hope you can get this resolved with ease.No need to reply to my last post here unless it is a last resort as it will keep your question locked to me and others will not be able to view it.
Thanks Pete