How JustAnswer Works:
  • Ask an Expert
    Experts are full of valuable knowledge and are ready to help with any question. Credentials confirmed by a Fortune 500 verification firm.
  • Get a Professional Answer
    Via email, text message, or notification as you wait on our site. Ask follow up questions if you need to.
  • 100% Satisfaction Guarantee
    Rate the answer you receive.
Ask Chris (aka- Moose) Your Own Question
Chris (aka- Moose)
Chris (aka- Moose), Technician
Category: Transmissions
Satisfied Customers: 48381
Experience:  16 yrs. experience with auto, manual, & CVT drivelines
2499435
Type Your Transmissions Question Here...
Chris (aka- Moose) is online now
A new question is answered every 9 seconds

Saturn: both the service light (looks like a transmission)

Customer Question

both the service light (looks like a transmission) and another light (looks like a trans with a down arrow) came on this morning. I am having trouble with acceleration from a s and are remaining on. top but once up to 40 MPh it does fine.

Submitted: 2 years ago.
Category: Transmissions
Expert:  Chris (aka- Moose) replied 2 years ago.
I am sorry for the delay in getting a response to you. Sometimes we get alot of customers and just can not keep up. Sometimes you just have to wait for the correct tech to login.Do you even still need help. Sometimes customers seek help elsewhere or figure it out on their own before we get to each and everyone.I am sure I can help a lot or a little at least something if you give me a chance and work with me. I am going to get an answer to you regardless if you reply or not sooner or later.If your concern is urgent reply and let me know and if you have anything more you think will help me, to help you, let me know. I work on here normally 3pm-3am central. Thanks Chris
Customer: replied 2 years ago.

I did my own research and found out the 04 had a ton of tranny issues. I did make it to work yesterday with it, low power in lower gears. On my drive home, the arrow down light was off, still lower power in low gears, but improved as I drove. I got home, parked. Had to run a short errand and no lights and power was fine

Expert:  Chris (aka- Moose) replied 2 years ago.
You forgot to mention what model vehicle this was. The good thing is these lights on have stored codes that will help us in correctly diagnosing and fixing it right the first time. If you can get it scanned that would be great. Based on your description I believe you have the CVT and its known for issues associated with pressure. You want a excellent 5 star answer & I would like to be rated the same for providing it. Consider I don't know your skill level & I can't see, smell, hear, or touch the vehicle. It may take a few back and forth replies. Try your best to respond with good detail so I can do the same. I normally log in at 3pm and work late. A rating is required. Your rating me, what I type. I am not an employee of this website, nor have control over the fees or the time it took to get a response. If you rate negative or not at all you still paid, but I get nothing. I want you pleased with me and my efforts, so let me know if your experience here has come up short.Thanks Chris
Customer: replied 2 years ago.

OK I will see what I can do to get it scanned. I drove it @ 15 miles today and nothing happened. It is the CVT :(

Expert:  Chris (aka- Moose) replied 2 years ago.
Super, and I need the model vehicle as well