How JustAnswer Works:
  • Ask an Expert
    Experts are full of valuable knowledge and are ready to help with any question. Credentials confirmed by a Fortune 500 verification firm.
  • Get a Professional Answer
    Via email, text message, or notification as you wait on our site. Ask follow up questions if you need to.
  • 100% Satisfaction Guarantee
    Rate the answer you receive.
Ask sprinkles08 Your Own Question
sprinkles08
sprinkles08, ASE Certified Technician
Category: Transmissions
Satisfied Customers: 23001
Experience:  Chrysler/Dodge/Jeep master tech ASE Master and Advanced Certified, Chrysler/Dodge/Jeep Master Certified, Trans Specialist
9825021
Type Your Transmissions Question Here...
sprinkles08 is online now
A new question is answered every 9 seconds

Lexus RX330: My rx330 wouldn't move when I put it to drive

Customer Question

My rx330 wouldn't move when I put it to drive or reverse although I felt the transmission engaging. When I pressed hard on the gas, I heard a loud popping sound and the car moved. What could be the problem? Thanks!
Submitted: 2 years ago.
Category: Transmissions
Expert:  sprinkles08 replied 2 years ago.
Hello and welcome to Justanswer!
The first thing I would suspect based on your description is a broken emergency brake shoe. It isn't uncommon for the shoe material to break free from it's backing plate and it will then wedge between the backing plate and rotor. This can prevent the vehicle from moving and will feel as if the brake is still pressed. If you felt the trans go into gear and it felt as if the brake was still pressed when trying to move then I would start by inspecting the emergency brake shoes.