How JustAnswer Works:
  • Ask an Expert
    Experts are full of valuable knowledge and are ready to help with any question. Credentials confirmed by a Fortune 500 verification firm.
  • Get a Professional Answer
    Via email, text message, or notification as you wait on our site. Ask follow up questions if you need to.
  • 100% Satisfaction Guarantee
    Rate the answer you receive.
Ask Roy Your Own Question
Roy
Roy, import/domestic specialest
Category: Transmissions
Satisfied Customers: 6175
Experience:  ASE master tech for 40 years
3506196
Type Your Transmissions Question Here...
Roy is online now
A new question is answered every 9 seconds

Transmisson question, working on 1999 ford ranger w/3.0, w/4r44e.

Customer Question

transmisson question, working on 1999 ford ranger w/3.0, w/4r44e. it doesn't move, zero line pressure, checked bolts in torque converter, there is no noise in transmisson, not low fluid, the filter is good, put new valve body and separator plate on it 2 years ago
Submitted: 2 years ago.
Category: Transmissions
Expert:  Roy replied 2 years ago.
good afternoon my name is ***** ***** I will assist it sounds like either the torque converter has failed internally, front pump has failed or one of the shafts going to the torque converter has stripped teeth. it sounds like it will have to come out and have the torque converter tested and remove the front pump to inspect Roy
Customer: replied 2 years ago.
if your sure it can't be anything else, we will the transmisson.
thanks
Expert:  Roy replied 2 years ago.
for no pump pressure. they are the 2 main items that control main line pressure. Roy