How JustAnswer Works:
  • Ask an Expert
    Experts are full of valuable knowledge and are ready to help with any question. Credentials confirmed by a Fortune 500 verification firm.
  • Get a Professional Answer
    Via email, text message, or notification as you wait on our site. Ask follow up questions if you need to.
  • 100% Satisfaction Guarantee
    Rate the answer you receive.
Ask Chris (aka-Moose) Your Own Question
Chris (aka-Moose)
Chris (aka-Moose), Auto Technician
Category: Toyota
Satisfied Customers: 947
Experience:  16 years of experience
2499435
Type Your Toyota Question Here...
Chris (aka-Moose) is online now
A new question is answered every 9 seconds

I have a 2006 sienna le and we changed fuel pumps 3x, we

Customer Question

Hello I have a 2006 sienna le and we changed fuel pumps 3x, we have spark, pressure and no leaks. We checked fuel relays and fuses everything is good...tried voltage check..its good we are at a loss as to what it would be
Submitted: 1 year ago.
Category: Toyota
Expert:  Kurt Kennedy replied 1 year ago.

So I can help you better, please tell me what the concern is? Will the car not start, is there a check engine light, etc.

Thank you.

Customer: replied 1 year ago.
It cranks but won't start we did everything
Customer: replied 1 year ago.
New fuel pumps 3x, we have pressure and spark but nothing seems to give us a clue as to why it isn't starting and staying tunning
Customer: replied 1 year ago.
running
Expert:  Kurt Kennedy replied 1 year ago.

Do you have a lab scope? Do you have any codes in the ECU?

Customer: replied 1 year ago.
No codes... Except for ABS
Expert:  Kurt Kennedy replied 1 year ago.

can you check the timing for me? These things are known for skipping teeth and timing belts breaking.

Customer: replied 1 year ago.
Will check that tomorrow
Customer: replied 1 year ago.
It run when you spray starter fluid in it
Customer: replied 1 year ago.
Could it be that the fuel injectors are clogged
Expert:  Kurt Kennedy replied 1 year ago.

If it runs when you spray starting fluid in it, then you dont need to check timing.

Could it be it has bad gas? do you have a EFI flush tool you can try to run the car off of know good gas, if not take a sample of the gas from the car

Customer: replied 1 year ago.
We took all the gas out and replaced it with new gas doing doing the same thing
Expert:  Kurt Kennedy replied 1 year ago.

actually, first things first. Check the 15a injector fuse under the hood in the relay box

Customer: replied 1 year ago.
No money
Expert:  Kurt Kennedy replied 1 year ago.

Huh?

Customer: replied 1 year ago.
Have power to the fuse
Customer: replied 1 year ago.
I can't have no more
Money
Expert:  Kurt Kennedy replied 1 year ago.

It sounds like if you have pressure at the rail, but the car doesnt start. BUT it will start with spraying cleaner in the intake, either the injectors are clogged (i have NEVER seen that in all my years at the toyota dealer) or the injectors do not have power or signal from the ECU.

Do the inejctors have 12v at the black/red wire to them all?

If so, you need to check the other wire on each injector for a "pulse" from the ECU

Customer: replied 1 year ago.
have power to the injectors awesome I have a pulse at the injectors
Customer: replied 1 year ago.
This is the first time this ever happens to me too I'll try tomorrow to see if injectors are clogged and I'll let you know tomorrow thank you for everything have a good night
Expert:  Kurt Kennedy replied 1 year ago.

no prob man. Keep me updated on what happens.

thanks