Subaru

Have Subaru questions? Ask a Subaru mechanic and get answers ASAP

Ask an Expert,
Get an Answer ASAP!

There was a 0336 which came up when the car wouldn't start…

Customer Question
Hi, there was a 0336...
Hi, there was a 0336 which came up when the car wouldn't start and the battery voltage went low. So preventavely replaced the camshaft sensor and battery . Still same outcome. Last night I removed the fuel filter and emptied it into a clear glass. Had about 1/5 the of water in there. My thinking is, if there is water in the filter (under the hood), then there might be a similar percentage in the tank ?
Submitted: 8 months ago.Category: Subaru
Show More
Show Less
Ask Your Own Subaru Question
Answered in 1 minute by:
11/12/2017
Subaru Mechanic: George H., Subaru Certified Technician replied 8 months ago
George H.
George H., Subaru Certified Technician
Category: Subaru
Satisfied Customers: 19,276
Experience: ASE Master Tech 15 + Years
Verified

Hello I will help,

Did you replace the cam and the crank sensor?

If you spray starting fluid in the intake will the engine start and run for a few seconds?

Ask Your Own Subaru Question
Customer reply replied 8 months ago
Hi George, replaced both sensors.the engine starts fine when cold and runs very smooth. Right now had the engine running at 72deg Celsius and turned it off AND the engine would not restart. Put 50ml fuel into the intake but wouldnt start. Also recognized that the shifter Relais for the gear shifter does not engage or disengage when pushing the brake. Very frustrating...
Subaru Mechanic: George H., Subaru Certified Technician replied 8 months ago

OK this is not what I got from your post so I will have to OPT OUT of your question. Maybe one of the other techs will be able to help

Ask Your Own Subaru Question
Subaru Mechanic: sprinkles08, ASE Certified Technician replied 8 months ago
sprinkles08
sprinkles08, ASE Certified Technician
Category: Subaru
Satisfied Customers: 24,064
Experience: ASE Master and Advanced level certified. Factory trained with 17 years dealership experience
Verified

Hello and welcome to JustAnswer! I apologize for the extended wait time you experienced, I've only just come online now and would like to assist you with your question.

P0336 is for the crank sensor's signal. If this is still setting then you do still have an issue with the crank sensor signal, whether it's a tone wheel problem, wiring, or the sensor itself. It's very possible that you have a bad replacement sensor. You definitely have a fuel contamination issue though.

No vehicle information was posted with the question. What year, make and model is the vehicle and what engine do you have?
Did you clear the P0336 to see if it or any other codes return?

Ask Your Own Subaru Question
Customer reply replied 8 months ago
Hi, the car is a 2000 Subaru Outback, sohc 2.5l automatic. I compared the old and new resistence of the sensors and they are identical. Wonder if there could be a timing issue. I lined up the timing marks for the camshaft pulleys and crankshaft sprocket according to the Haynes manual, but will check again Monday morning. Would an offset of one tooth on one of the camshaft pulleys cause the engine to start up bad when warmed up ? Thougt that the time advancing is different for cold and warm engines .
Customer reply replied 8 months ago
Hi, yes I cleared the 0336 but it never came up, really. What is sense is when I start up the cold engine the starter turns once or twice and gets a very hard reaction from the engine itself. Feels like the engine wants to go against the starter but then finally starts. Definitely hard on the starter.
Subaru Mechanic: sprinkles08, ASE Certified Technician replied 8 months ago
Has the battery been load tested?
Ask Your Own Subaru Question
Customer reply replied 8 months ago
Hi, the battery is new
Subaru Mechanic: sprinkles08, ASE Certified Technician replied 8 months ago

It was replaced to try to repair the current problem and there was no change in cranking speed?

Ask Your Own Subaru Question
Customer reply replied 8 months ago
No, basically the same.
Subaru Mechanic: sprinkles08, ASE Certified Technician replied 8 months ago

Is there any abnormal noise once the engine starts?

Ask Your Own Subaru Question
Customer reply replied 8 months ago
No, sounds smooth
Subaru Mechanic: sprinkles08, ASE Certified Technician replied 8 months ago

What year, make and model is the vehicle and what engine do you have?

Ask Your Own Subaru Question
Customer reply replied 8 months ago
Hi, thought I sent this to you already. 2000 Subaru Outback ,2.5l automatic Sohc
Subaru Mechanic: sprinkles08, ASE Certified Technician replied 8 months ago

I'm a full time tech and at work this afternoon, I'll get back to you as quickly as I can.

Ask Your Own Subaru Question
Subaru Mechanic: sprinkles08, ASE Certified Technician replied 8 months ago

I didn't see one of your posts previously but do now.

When was cam timing disturbed opposed to the current symptoms starting?

Ask Your Own Subaru Question
Customer reply replied 8 months ago
Hi, the only time when cam timing came up was when the battery got low after trying to turn on the warm engine. That was the only time when error code 336 came up. After that , never again.1 I replaced both camshaft and crankshaft sensor2 bought a new battery3 reset error code4 started the engine cold and ran perfectly smooth5 EVERY time I turn off the engine when warm, I cannot restart for a few hours6 no error codes , also never let the battery go too low.7 last night emptied fuel filter and removed water with air pressure and alcohol. Added fuel injector cleaner to the tank this morning.8 engine started fine this morning. Not restarting after warming up9 in the afternoon checked the timing again ,(new belt) and it lines up perfect, so timing is good10 emptied fuel filter sgain and no water inside (checked with a clear glass). Started the cold engine and ran fine11 turned off engine and wouldn't start when warm. Checked for sparks , NO spark ,!!! So engine does not produce spark when trying to start the warm engine12 replaced spark plugs , enginenot starting when warm13 checked All fuses. Fuses ok .Any ideas ?Harry
Subaru Mechanic: sprinkles08, ASE Certified Technician replied 8 months ago

When was the timing belt replaced as opposed to the current problem starting?

Ask Your Own Subaru Question
Customer reply replied 8 months ago
At 192,000km. Engine had now slightly over 193,800km on it
Subaru Mechanic: sprinkles08, ASE Certified Technician replied 8 months ago

After having the no start condition with lost spark did you check for fault codes again?

Ask Your Own Subaru Question
Customer reply replied 8 months ago
no fault codes
Subaru Mechanic: sprinkles08, ASE Certified Technician replied 8 months ago

Are you using a generic code reader or an actual scan tool?

Ask Your Own Subaru Question
Customer reply replied 8 months ago
Obd2 scanner. Look, don't want to be rude, but if you have a hint of what is going on, it might be nice to share it. If the car is running while warmed up, it means that the ignition and timing sensors work. Turning off and on again might indicate a stick or dirty or burned Relais , Don't you think ?
Customer reply replied 8 months ago
I mean a stuck Relais...
Subaru Mechanic: sprinkles08, ASE Certified Technician replied 8 months ago

It's going to require testing to determine what is wrong. It isn't possible to know exactly what is wrong based on a problem description.

The fact that it runs sometimes doesn't rule out any components. When it doesn't run it's because something in the ignition system isn't working.

If you don't know if you're using a code reader or a scan tool then you can post the brand and model. An actual scan tool is going to be necessary to proceed with testing.

Ask Your Own Subaru Question
Was this answer helpful?

How JustAnswer works

step-image
Describe your issueThe assistant will guide you
step-image
Chat 1:1 with a subaru mechanicLicensed Experts are available 24/7
step-image
100% satisfaction guaranteeGet all the answers you need
Ask sprinkles08 Your Own Question
sprinkles08
sprinkles08
sprinkles08, ASE Certified Technician
Category: Subaru
Satisfied Customers: 24,064
24,064 Satisfied Customers
Experience: ASE Master and Advanced level certified. Factory trained with 17 years dealership experience

sprinkles08 is online now

A new question is answered every 9 seconds

How JustAnswer works:

  • Ask an ExpertExperts are full of valuable knowledge and are ready to help with any question. Credentials confirmed by a Fortune 500 verification firm.
  • Get a Professional AnswerVia email, text message, or notification as you wait on our site. Ask follow up questions if you need to.
  • 100% Satisfaction GuaranteeRate the answer you receive.

JustAnswer in the News:

Ask-a-doc Web sites: If you've got a quick question, you can try to get an answer from sites that say they have various specialists on hand to give quick answers... Justanswer.com.
JustAnswer.com...has seen a spike since October in legal questions from readers about layoffs, unemployment and severance.
Web sites like justanswer.com/legal
...leave nothing to chance.
Traffic on JustAnswer rose 14 percent...and had nearly 400,000 page views in 30 days...inquiries related to stress, high blood pressure, drinking and heart pain jumped 33 percent.
Tory Johnson, GMA Workplace Contributor, discusses work-from-home jobs, such as JustAnswer in which verified Experts answer people’s questions.
I will tell you that...the things you have to go through to be an Expert are quite rigorous.

What Customers are Saying:

I would (and have) recommend your site to others I was quite satisfied with the quality of the information received, the professional with whom I interacted, and the quick response time. Thanks, and be sure that I'll be back whenever I need a question answered in a hurry.

Stephanie PElm City, NC

used your service this weekend with "Trecers" help. thank you ,thank you, thank you. replaced an A/C fan motor. Local Auto Zone had part. $15.00 "tracer" fee and $40.00 for parts, I saved several hundreds of dollers at a shop. i will recommend you and use you in the future.

David L.Richmond, TX

9 dollars, 2 hours of my time, and I drove away. Your diagnosis was right on the mark. Thank you so much.

PhilMarysville, CA

Lurch. Thank you very much. I had real doubts about this website but your promptness of response, quick followup and to the point answer with picture was incredible.

CharlesWalnut Creek, CA

As a single woman, I really appreciate an excellent and affordable opinion.
Thank you Geordie, I will not hesitate to contact justanswer in the future!

SueCharleston, WV

Another great insight to what may be the problem. I will have my mechanic take a look at it tomorrow. Thanks again, Frank...you do indeed know your stuff.

JimCastleberry, FL

Wonderful service, prompt, efficient, and accurate. Couldn't have asked for more. I cannot thank you enough for your help.

Mary C.Freshfield, Liverpool, UK

< Previous | Next >

Meet the Experts:

Kevin C.

Kevin C.

Subaru Master Tech.

1,727 satisfied customers

34 years of Subaru service experience, ASE Master Technician.

George H.

George H.

Subaru Certified Technician

19,276 satisfied customers

ASE Master Tech 15 + Years

Tim Mohr

Tim Mohr

ASE MASTER TECH

418 satisfied customers

30 YRS EXPERIENCE, FOREIGN AND DOMESTIC, GAS AND DEISEL

Matt

Matt

Engineer

373 satisfied customers

Mechanical Engineer with 20 years experience in the auto industry, 8 yrs in formula 1 engine testing

Chris(aka-Moose)

Chris(aka-Moose)

Subaru Technician

332 satisfied customers

16 years of experience

Ron Z.

Ron Z.

- Subaru Tech -

260 satisfied customers

18+yrs experience. State Inspector and Subaru Diagnostics

Don - Mo Lurch

Don - Mo Lurch

Subaru Mechanic

193 satisfied customers

Heavy Line Mech, Race Shop Owner, Mobile Electronics.

< Previous | Next >

Related Subaru Questions
I purchased 05 Outback xt was told has no power poss clogged
Hello Kevin I purchased 05 Outback xt was told has no power poss clogged cat but they had no clue I towed home started car had rattle and smoked after running up to temp idling cel on for tumbler gen … read more
Matt
Matt
Engineer
Bachelor's Degree
373 satisfied customers
I have a 2011 Subaru Outback that recently came up with a
I have a 2011 Subaru Outback that recently came up with a dead battery. I replaced the battery, but the ABS, VDC, and brake lights all came on and are staying on. Any ideas? Could the low battery trig… read more
baddad1
baddad1
technician
High School or GED
5 satisfied customers
I am mostly concerned with all the rest of my question
I am mostly concerned with all the rest of my question regarding fuel. I was just trying to be complete. TT the dealer yesterday and they told me they did check the fuel pump relay before determining … read more
baddad1
baddad1
technician
High School or GED
5 satisfied customers
S. , My 2006 subaru outback went swimming. flood this
My 2006 subaru outback went swimming. flood this spring. have been driving it since. trowingCEL P1560 code.Google brings me to this link:http://www.justanswer.com/subaru/2tin5-2002-subaru-outback-gives-code-p1560-backup-battery-volts-low.html#re.v/462/I pulled the ECU and washed with isopropal and dried out, no difference. I can reset the code of course, but it comes back immedialtey.no "fuse #5" from the link above in the under hood fuse box. Also, no "connector B139" in the drawing at the link above.Also one valve sensor low voltage error, but it cleared and hasn't came back.Also, just started "surging" at 4000 rpm. doesn't matter engine load or gear, at 4000 rpm, engine will start cutting out and cutting back in. about once or twice a second. … read more
fordguy4u
fordguy4u
Automotive Tech
Vocational, Technical or Trade Scho
70 satisfied customers
Subaru Forester: I have a 2009 forester. Problem started with
I have a 2009 forester. Problem started with low tire pressure light, followed a few days later by check engine an others. Have take to a local garage twice, and Subaru garage once. In every case they… read more
BOBBYSS
BOBBYSS
TECHNICIAN/ADVISOR
Associate Degree
8,343 satisfied customers
Subaru Impreza: New 2015 Impreza 5 door Premium w/CVT, 900
New 2015 Impreza 5 door Premium w/CVT, 900 miles. I drive the same route 7 days a week, and have several "stop, then turn right" situations. Once or twice a week I'll get most of the way through the t… read more
tamaz22
tamaz22
60 satisfied customers
Subaru Outback: I ran my 2003 Subaru outback wagon H-6 into
I ran my 2003 Subaru outback wagon H-6 into the ditch during a snow storm Saturday. When we got it pulled out my ABS, Brake, and Battery lights were on. The brakes seem to work fine. I drove it home a… read more
BOBBYSS
BOBBYSS
TECHNICIAN/ADVISOR
Associate Degree
8,343 satisfied customers
Subaru Legacy GT Limited: Kevin I have a 2003 Subaru Legacy
Kevin I have a 2003 Subaru Legacy GT. My wife got home last night, car was working great and always works great. She went to satrt it, engine turns over but won't start. Any suggestions for me to try?… read more
tamaz22
tamaz22
60 satisfied customers
Subaru Legacy L: 2001 Legacy L wont start. Car ran fine the
2001 Legacy L won't start. Car ran fine the day before. Came out the next morning and it caught on first crank like always, then died. Now it won't start. CEL is NOT on. Car cranks fine. Voltage at ba… read more
Matt
Matt
Engineer
Bachelor's Degree
373 satisfied customers
Subaru Forester: I have p0325 and p0341 Codes on my subary.
I have p0325 and p0341 Codes on my subary. Where should i start diagnosing this issue? 2.5L Manual Transmission. Car runs fine without any noticable issues.… read more
Paul M ASE Master
Paul M ASE Master
Automotive College
3,307 satisfied customers
2009 Forester: 300 miles..getting on the freeway, it just shut down
About a month ago, I bought a 2009 Forester with 12, 500 on it but have only put about 300 miles on it. Just now, as I was getting on the freeway, it just shut down. It will start and then immediately… read more
Todd Green
Todd Green
Associate
3 satisfied customers
2002 Outback: she felt a thud..about a mile..speedometer needle went
My wife was driving her 2002 Outback when she felt a thud "under the car". She continued to drive it for about a mile, and noted a decrease in engine responsiveness. As she slowed to turn right, the s… read more
baddad1
baddad1
technician
High School or GED
5 satisfied customers
87 Subaru Legacy: getting fuel..knocking..his drive home..car today
87 Subaru Legacy - turns over fine but does not seem to be getting fuel to the engine for ignition to happen. Son's car - he filled it yesterday and started having engine knocking problems on his driv… read more
Kevin C.
Kevin C.
Subaru Master Tech.
High School or GED
1,727 satisfied customers
2003 forester: stop light..accelerator..shifted..3500 rpms
I just bought a 2003 forester 2.5xs, automatic transmision, with every option...I thought I test drove it enough before buying it, but... on the way home I noticed the engine flutters when i step down… read more
Randall
Randall
Auto Technician / Consultant
Vocational, Technical or Trade Scho
69 satisfied customers
2005 forester: motor oil..drained..pure synthetic oil..refilled
My boyfriend was trying to change the oil in my 2005 forester and he ended up draining the transmission fluid instead of the motor oil. He didn't realize he drained the wrong one until he over-filled … read more
baddad1
baddad1
technician
High School or GED
5 satisfied customers
Subaru Legacy Outback: the fuel filter..put gas..car wont start
Where is the fuel filter on a Subaru Legacy Outback 2008? I think I have had bad gas. I had to put gas in from a gas and now the car won't start after running badly right after I put it in the tank. C… read more
baddad1
baddad1
technician
High School or GED
5 satisfied customers
98 Subaru Forester: hood..overheating..temp gauge..fluid level
I just had my oil changed last week and now my 98 Subaru Forester starts smoking after 30 minutes of driving. Looking under the hood, I can see it's steam, not smoke, and that water is dripping from a… read more
Joe
Joe
Shop supervisor
Vocational, Technical or Trade Scho
581 satisfied customers
1987 Subaru GL: Wagon..5 speed manual transmission..wheel drive
I have a 1987 Subaru GL Wagon, 5 speed manual transmission, dual rangeXXXXX 287,788 miles. It hasn't run regularly for about 4 years. The last time I drove it, the car had good power and idling, but n… read more
supermechanic
supermechanic
Service consultant
Vocational, Technical or Trade Scho
10 satisfied customers
Disclaimer: Information in questions, answers, and other posts on this site ("Posts") comes from individual users, not JustAnswer; JustAnswer is not responsible for Posts. Posts are for general information, are not intended to substitute for informed professional advice (medical, legal, veterinary, financial, etc.), or to establish a professional-client relationship. The site and services are provided "as is" with no warranty or representations by JustAnswer regarding the qualifications of Experts. To see what credentials have been verified by a third-party service, please click on the "Verified" symbol in some Experts' profiles. JustAnswer is not intended or designed for EMERGENCY questions which should be directed immediately by telephone or in-person to qualified professionals.

Disclaimer: Information in questions, answers, and other posts on this site ("Posts") comes from individual users, not JustAnswer; JustAnswer is not responsible for Posts. Posts are for general information, are not intended to substitute for informed professional advice (medical, legal, veterinary, financial, etc.), or to establish a professional-client relationship. The site and services are provided "as is" with no warranty or representations by JustAnswer regarding the qualifications of Experts. To see what credentials have been verified by a third-party service, please click on the "Verified" symbol in some Experts' profiles. JustAnswer is not intended or designed for EMERGENCY questions which should be directed immediately by telephone or in-person to qualified professionals.

Show MoreShow Less

Ask Your Question

x