How JustAnswer Works:
  • Ask an Expert
    Experts are full of valuable knowledge and are ready to help with any question. Credentials confirmed by a Fortune 500 verification firm.
  • Get a Professional Answer
    Via email, text message, or notification as you wait on our site.
    Ask follow up questions if you need to.
  • 100% Satisfaction Guarantee
    Rate the answer you receive.
Ask Ricardo Hohl Your Own Question
Ricardo Hohl
Ricardo Hohl, Master Certified Tech
Category: Subaru
Satisfied Customers: 4241
Experience:  Automotive instructor at Porter and Chester institute
14457476
Type Your Subaru Question Here...
Ricardo Hohl is online now
A new question is answered every 9 seconds

Just bought an 06 Legacy, just bought an 06 legacy. Right

Customer Question

just bought an 06 Legacy
JA: Are you fixing your Legacy yourself? What have you tried so far?
Customer: just bought an 06 legacy. Right after I bought it I went to show it to a friend, turned the car off and then when I restarted it the engine was running but the accelerator didn't cause the engine to rev. I turned it off and the first time I tried to restart it it would crank but not turn over and start, turned it off again and tried to start it and it started right up and was fine except the check engine light came on. The next morning the check engine light was off, car ran fine for a week and then today it did the same thing again.
JA: Does the light stay on, or does it blink?
Customer: the check engine light is solid but the cruise light was blinking
JA: Anything else you want the mechanic to know before I connect you?
Customer: The first time it happened I took it to my mechanic and even though the light was off he plugged it in and got a code but I can't remember what he said but it had to do with a plug close to the air filter box and he said the a couple of the pins needed to be adjusted. Today when it happened I was 200 miles from home so I just disconnected the battery and manually reset the computer so I could get home..
Submitted: 2 months ago.
Category: Subaru
Customer: replied 2 months ago.
No, I have a mechanic but this is the first time he's seen this. I'm not a spring chicken anymore so I don't jump in like I used to lol. He said a couple of pins on the white plug close to the air filter box were pushed in just a tiny bit and he adjusted them but said that probably wasn't it.
Customer: replied 2 months ago.
Just thought of something that may or may not matter. Both times this happened the car was only off for 15 or 20 minutes. Typically I don't start the car back up that quickly.
Expert:  Ricardo Hohl replied 2 months ago.

Hi welcome to just answers my name is ***** ***** plug you are mentioning may be the MAf air flow sensor, but to be more sure you need to have the computer scanned and get the codes there should be memory stored on the computer from the last time when this happen. if you get the codes get back to me i will be able to be more accurate on what you need to do to fix it.

Customer: replied 2 months ago.
If he checks the codes and get them back to you will there. E another charge? I'm on a limited income right now but the mechanic and I are both stymied.
Expert:  Ricardo Hohl replied 2 months ago.
Hi did you check for codes?
Customer: replied 2 months ago.
I'm taking it Monday to have him recheck it. I'll let you know then. Thanks.
Expert:  Ricardo Hohl replied 2 months ago.
Ok