How JustAnswer Works:
  • Ask an Expert
    Experts are full of valuable knowledge and are ready to help with any question. Credentials confirmed by a Fortune 500 verification firm.
  • Get a Professional Answer
    Via email, text message, or notification as you wait on our site. Ask follow up questions if you need to.
  • 100% Satisfaction Guarantee
    Rate the answer you receive.
Ask Kevin C. Your Own Question
Kevin C.
Kevin C., Subaru Master Tech.
Category: Subaru
Satisfied Customers: 1727
Experience:  34 years of Subaru service experience, ASE Master Technician.
49406277
Type Your Subaru Question Here...
Kevin C. is online now
A new question is answered every 9 seconds

2006 Tribeca b9...disconnected instrument cluster

Customer Question

2006 Tribeca b9...disconnected instrument cluster for about 5 mins now the tach and speedometer don't work they do bounce a little bit all gauges worked fine prioir to this. I have checked all connections they are good
Submitted: 2 years ago.
Category: Subaru
Expert:  tamaz replied 2 years ago.
Hi,what was the reason for removing cluster?Do you have any warning lights on the dash?How does vehicle run?Just a few questions to get us started,thanks
Customer: replied 2 years ago.
Runs fine was trying to get paper out of vents and I unplugged cluster everything works but tach and speedo
Expert:  tamaz replied 2 years ago.
I know you said the connections are good but please check the connection where it enters the cluster,that connector can be tough sometimes and I've found in the past pulling on the those wires cause a poor connection.Because everything was operating good before this the problem must be at the connection or meter failure