How JustAnswer Works:
  • Ask an Expert
    Experts are full of valuable knowledge and are ready to help with any question. Credentials confirmed by a Fortune 500 verification firm.
  • Get a Professional Answer
    Via email, text message, or notification as you wait on our site. Ask follow up questions if you need to.
  • 100% Satisfaction Guarantee
    Rate the answer you receive.
Ask Curtis B. Your Own Question
Curtis B.
Curtis B., Technician
Category: Small Engine
Satisfied Customers: 28910
Experience:  have worked on and around most engine models for 35 yrs./Polaris ATV expert
30244710
Type Your Small Engine Question Here...
Curtis B. is online now
A new question is answered every 9 seconds

I have a KDE 6700TA Kipor generator, and is not starting

This answer was rated:

Hi, I have a KDE 6700TA Kipor generator, and is not starting anymore. It have power (new battery) but when I turn the key nothing happens
JA: I'll do all I can to help. How long have you been dealing with this?
Customer: 8 years and no problem with it.
JA: Do you plan on doing the work yourself?
Customer: In the first phase yes, if is something simple like a fuse
JA: Anything else we should know to help you best?
Customer: no, that's all. I want to figure out if is a fuse or a contact or the starter

Welcome to JUST ANSWER small engines, let me try to help you !! I don't know it all, but maybe together we can get you a satisfactory answer!

Follow the positive battery cable direct to the starter solenoid/relay, and jump from the battery cable terminal, to the single switch terminal on the same solenoid. Engine should engage the starter and spin engine. This is test of battery, cables, solenoid and starter. I fit does spin engine, look for an inline fuse for the ignition system. The switch for start is not getting voltage.

Curtis B. and other Small Engine Specialists are ready to help you
Customer: replied 30 days ago.
Hi Curtis, problem solved. It was the inline fuse from the starter.

Thank you!