How JustAnswer Works:
  • Ask an Expert
    Experts are full of valuable knowledge and are ready to help with any question. Credentials confirmed by a Fortune 500 verification firm.
  • Get a Professional Answer
    Via email, text message, or notification as you wait on our site. Ask follow up questions if you need to.
  • 100% Satisfaction Guarantee
    Rate the answer you receive.
Ask Curtis B. Your Own Question
Curtis B.
Curtis B., Technician
Category: Small Engine
Satisfied Customers: 13581
Experience:  have worked on and around most engine models for 35 yrs./Polaris ATV expert
30244710
Type Your Small Engine Question Here...
Curtis B. is online now
A new question is answered every 9 seconds

Hank, how are you I have a 17500 guardian ultra source and

Customer Question

Hey hank, how are you I have a 17500 guardian ultra source and it starts and runs but not generating no power.
Submitted: 1 month ago.
Category: Small Engine
Expert:  Hank F. replied 1 month ago.

Hello, thank you for requesting me!

I noticed no one else has helped you, so I am going to do my best.
I’m really sorry you had to wait so long for a reply. I can’t speak for anyone else, but I work 2 day jobs, and normally help on Just Answer in the evenings. I was at work all day.
Although I can’t be online 24/7, I am on almost every single day -often only getting 3 or 4 hours sleep, due to me spending so much time trying to help others.

If at any point, you feel you can’t work around this schedule, please just let me know, instead of leaving me negative feedback, and I will opt out. But I do have to consider my full time job.

If you are not getting power out, I have uploaded a test for you to do.

Please do test #4, and let me know all the results.

When giving the results, please give me wire numbers, not step numbers.

IE - say "wire 2 to 6 gave 35VAC", not "step 5 gave 35VAC". This makes it much quicker for me to reference and compare the results.

Click here to download the test.