How JustAnswer Works:
  • Ask an Expert
    Experts are full of valuable knowledge and are ready to help with any question. Credentials confirmed by a Fortune 500 verification firm.
  • Get a Professional Answer
    Via email, text message, or notification as you wait on our site. Ask follow up questions if you need to.
  • 100% Satisfaction Guarantee
    Rate the answer you receive.
Ask Hank F. Your Own Question
Hank F.
Hank F., Technician
Category: Small Engine
Satisfied Customers: 15274
Experience:  Certified on Onan and Generac generators
19372534
Type Your Small Engine Question Here...
Hank F. is online now
A new question is answered every 9 seconds

I have an onan 3.7pfi-3p genset... has always worked,,,

Customer Question

I have an onan 3.7pfi-3p genset... has always worked,,, still starts fine, but now not getting AC output 120 or 240. checked brushes(almost new) checked rectifier(tests goood) measered resistance between + and -(brushes installed, no wires connected) get between 50 and 100 ohms(have had different readings in between starts) I figure the magnetic field has died... manual says 6vdc battery(10 ohm resistor and diode) run engine connect to +p terminal, wait for AC to begin rising then disconnect battery,,, this does not seam to work,,, is there another wat?
JA: Do you have fuel in the tank? If so, is the shut-off valve open and the fuel clean?
Customer: rngine starts fine, no issues with motor
JA: Do you plan on doing the work yourself?
Customer: yes
JA: Anything else we should know to help you best?
Customer: dont thimk so
Submitted: 1 month ago.
Category: Small Engine
Expert:  Hank F. replied 1 month ago.

Hello, my name is ***** ***** I am going to assist you with this.

Is there more to the model number than that? There should be a spec letter in there somewhere.

What manual are you using?

Customer: replied 1 month ago.
3.7PFI -3P/J1
Customer: replied 1 month ago.
Major service manual YCB Alternator 1200 - 6500 watts 50 and 60 Hertz (###) ###-####6-82
Expert:  Hank F. replied 1 month ago.

OK.

If the field flash did nor work, you either have bad capacitors or windings.

You need to do the rest of the tests in the book, particularly test G, H and J.

Customer: replied 1 month ago.
I have not done G as the J spec does not havr the capacitor, H passes.... have nor done J... will work on that now... figured if it gets this far,,, i am screwed..... will let you know what i find...
Expert:  Hank F. replied 1 month ago.

Ok.