How JustAnswer Works:
  • Ask an Expert
    Experts are full of valuable knowledge and are ready to help with any question. Credentials confirmed by a Fortune 500 verification firm.
  • Get a Professional Answer
    Via email, text message, or notification as you wait on our site.
    Ask follow up questions if you need to.
  • 100% Satisfaction Guarantee
    Rate the answer you receive.
Ask JohnF2015 Your Own Question
JohnF2015
JohnF2015, Small Engine Technician
Category: Small Engine
Satisfied Customers: 1102
Experience:  Owner/Service Technician at S & J Small Engines
87465640
Type Your Small Engine Question Here...
JohnF2015 is online now
A new question is answered every 9 seconds

The generator that I have is a generac 8000 to 12000 the

Customer Question

The generator that I have is a generac 8000 to 12000 the engine runs fine but while I was Using generator the saw that I was using started running real slow. I shut the saw off and tried again and now it does not run at all. The breakers seem fine also the ground faults seem fine and the 220 breaker is okay but just not producin any electricty any ideas
Submitted: 8 months ago.
Category: Small Engine
Expert:  JohnF2015 replied 8 months ago.

Hi, my name is***** will be assisting you.

It sounds like the AVR or voltage regulator has gone bad and is causing the unit to not produce any voltage to the control panel. This is the spot where I would start with troubleshooting or repairing the issue.

Thank you it has been a pleasure to assist you.

Please take a moment to rate your experience.