How JustAnswer Works:
  • Ask an Expert
    Experts are full of valuable knowledge and are ready to help with any question. Credentials confirmed by a Fortune 500 verification firm.
  • Get a Professional Answer
    Via email, text message, or notification as you wait on our site. Ask follow up questions if you need to.
  • 100% Satisfaction Guarantee
    Rate the answer you receive.
Ask Curtis B. Your Own Question
Curtis B.
Curtis B., Technician
Category: Small Engine
Satisfied Customers: 13581
Experience:  have worked on and around most engine models for 35 yrs./Polaris ATV expert
30244710
Type Your Small Engine Question Here...
Curtis B. is online now
A new question is answered every 9 seconds

Put new plugs in and it started right up and ran for about

Customer Question

Put new plugs in and it started right up and ran for about 10 minutes then died and wont restart. Pulled the plugs and rechecked the gap set at40. Can't find any loose wires
JA: Do you have fuel in the tank? If so, is the shut-off valve open and the fuel clean?
Customer: Getting plenty of fuel. Running out the overflow tube but not flooded
JA: Do you plan on doing the work yourself?
Customer: Yes
JA: Anything else we should know to help you best?
Customer: Is it normal for gas to run out the overflow after shutting off the motor
Submitted: 12 months ago.
Category: Small Engine
Expert:  Curtis B. replied 12 months ago.

Welcome to JUST ANSWER small engines, let me try to help you !! I don't know it all, but maybe together we can get you a satisfactory answer!

Expert:  Curtis B. replied 12 months ago.

Make and model? Fuel, gas or lp? Engine make and model? Single cylinder or twin? Do you have spark at the plug?

Customer: replied 12 months ago.
Kubota wg 750 3 cylinder gas. Yes I have spark
Customer: replied 12 months ago.
Out new plugs in ran for ten minutes then died wont re start
Expert:  Curtis B. replied 12 months ago.

If you have fuel coming out the overflow on the carburetor, the carburetor is flooding the cylinders. Shut off the fuel and see if you can get engine to run. Sounds like the needle valve in the carburetor is stuck.