How JustAnswer Works:
  • Ask an Expert
    Experts are full of valuable knowledge and are ready to help with any question. Credentials confirmed by a Fortune 500 verification firm.
  • Get a Professional Answer
    Via email, text message, or notification as you wait on our site.
    Ask follow up questions if you need to.
  • 100% Satisfaction Guarantee
    Rate the answer you receive.
Ask Curtis B. Your Own Question
Curtis B.
Curtis B., Technician
Category: Small Engine
Satisfied Customers: 28106
Experience:  have worked on and around most engine models for 35 yrs./Polaris ATV expert
30244710
Type Your Small Engine Question Here...
Curtis B. is online now
A new question is answered every 9 seconds

Purchased a used Deere LA145 riding mower. installed new

Customer Question

purchased a used John Deere LA145 riding mower. installed new blades. when I engage he blades, I get a bad squealing noise. could it be the belt(s)?
JA: What's the make and model of the mower? And can you guesstimate how old it is?
Customer: According to S/N plate, DOM was 2010. it has 88 hours on it.
JA: Do you plan on doing the work yourself?
Customer: if it's a no brainer
JA: Anything else we should know to help you best?
Customer: it's the noise - I cut a 30 foot swath, but the noise was terrible.
Submitted: 11 months ago.
Category: Small Engine
Expert:  Curtis B. replied 11 months ago.

See link above. Is the belt tight with engine off and deck engaged? Noise can be from belt slipping, or any of the pulleys on the deck having a bad bearing.

Expert:  Curtis B. replied 11 months ago.

# 7 in the link is the spring that keeps the belt tight, is it in place?

Expert:  Curtis B. replied 11 months ago.

I see question still open, did you see my response?