How JustAnswer Works:
  • Ask an Expert
    Experts are full of valuable knowledge and are ready to help with any question. Credentials confirmed by a Fortune 500 verification firm.
  • Get a Professional Answer
    Via email, text message, or notification as you wait on our site. Ask follow up questions if you need to.
  • 100% Satisfaction Guarantee
    Rate the answer you receive.
Ask peterpete190 Your Own Question
peterpete190
peterpete190,
Category: Small Engine
Satisfied Customers: 29067
14928985
Type Your Small Engine Question Here...
peterpete190 is online now
A new question is answered every 9 seconds

10Kw Generac. Failed to start on weekly start. Over temp

Customer Question

10Kw Generac. Failed to start on weekly start. Over temp light. Switched off and light cleared. It starts but stops after 20 seconds or so, restarts and stops several times. I just changed the Oil, filter and air filter. No change. STill starts but stops and cycles on and of.
JA: Do you have fuel in the tank? If so, is the shut-off valve open and the fuel clean?
Customer: I am running it from two linked 10lb Propane tanks which are half full. No previous problems form them but it could be that
JA: Do you plan on doing the work yourself?
Customer: That was the intention. Until I run out off ideas then I would call in the professional. I am an engineer but not experienced on these.
JA: Anything else we should know to help you best?
Customer: It has been running reliably for several years. Only once been used for about 7 hours during a power outage. 84 hours on the clock. It is about 12 years old.
JA: OK. Got it. I'm sending you to a secure page on JustAnswer so you can place the $5 fully-refundable deposit now. While you're filling out that form, I'll tell the Small Engine Technician about your situation and then connect you two.
Submitted: 1 year ago.
Category: Small Engine
Expert:  peterpete190 replied 1 year ago.

My name is ***** ***** I am a professional here at Just Answer. I noticed that your question had not received a response and thought I would see if you still need help with this.I apologize for the delay and I hope I can still assist you with this here.My info is somewhat limited on your model here but I had seen no one else has responded and would like to see if I can help here.If at any time you feel that I cannot help with this please let me know.

I see no one has posted any help with this here.In some cases this can be due to the info you may be looking for may be difficult to obtain or the correct person that can help may not be online.

In some cases this type of fault here can be caused by an internal electrical fault with the temp sensor itself.I have seen the temp sensor act up/fail before in the past needing replaced for issues like this here.Unfortunately it is difficult to pinpoint the exact fault from here without seeing your model so this will have to be tested further to be sure of the cause and then repaired from there.

If more help is needed, use the reply tab to continue our conversation. If no further assistance is needed, kindly rate my service.You can rate at any time and we can continue to work on your question as this will not close out your question.Keep in mind in some cases it can be difficult to fully diagnose or help repair your vehicle without seeing it and I work on delivering the best possible answer from what I see to work with.

Thanks Pete

Customer: replied 1 year ago.
Thanks Pete, but I called a local authorized service company and they sent someone out to check it out. Seems one of the rotor windings is open circuit so we are looking to get a replacement part.
No further action needed from you. Thanks.
Expert:  peterpete190 replied 1 year ago.

That is great to hear the fault has been located.If you need anything else here let me know.

Thanks Pete