How JustAnswer Works:
  • Ask an Expert
    Experts are full of valuable knowledge and are ready to help with any question. Credentials confirmed by a Fortune 500 verification firm.
  • Get a Professional Answer
    Via email, text message, or notification as you wait on our site. Ask follow up questions if you need to.
  • 100% Satisfaction Guarantee
    Rate the answer you receive.
Ask JohnF2015 Your Own Question
JohnF2015
JohnF2015, Small Engine Technician
Category: Small Engine
Satisfied Customers: 1132
Experience:  Owner/Service Technician at S & J Small Engines
87465640
Type Your Small Engine Question Here...
JohnF2015 is online now
A new question is answered every 9 seconds

I have a Stihl BR350 backpack blower. It didn't want to stay

Customer Question

Hi I have a Stihl BR350 backpack blower. It didn't want to stay on so I purchase a new carb for it and installed it. Now I can started and stays on but no power as I hit the throttle. I do want to make it clear that the ignition coil had been cut and tapped into by another wire and boot. Will an ignition coil cause this?
Submitted: 2 years ago.
Category: Small Engine
Expert:  JohnF2015 replied 2 years ago.

Hi, my name is***** will be assisting you.

No, it is not likely that the coil is the problem. If the coil were a problem most likely the machine would not run at all.

Have you checked the exhaust for blockage. The muffler screen and or the exhaust port on the cylinder could be partially blocked causing enough back pressure to keep the machine from coming up to full throttle.

Expert:  JohnF2015 replied 2 years ago.

Hi, my name is***** will be assisting you.

No, it is not likely that the coil is the problem. If the coil were a problem most likely the machine would not run at all.

Have you checked the exhaust for blockage. The muffler screen and or the exhaust port on the cylinder could be partially blocked causing enough back pressure to keep the machine from coming up to full throttle.

Customer: replied 2 years ago.

Yes I checked for carbon build up and looked ok

Customer: replied 2 years ago.

I haven't checked fuel filter though

Expert:  JohnF2015 replied 2 years ago.

It could be the fuel filter, it may allow enough fuel to pass through to run a low speed but not enough to run at full throttle. Have you tried to run with the air filter off of the machine? Does it make any difference?