How JustAnswer Works:
  • Ask an Expert
    Experts are full of valuable knowledge and are ready to help with any question. Credentials confirmed by a Fortune 500 verification firm.
  • Get a Professional Answer
    Via email, text message, or notification as you wait on our site.
    Ask follow up questions if you need to.
  • 100% Satisfaction Guarantee
    Rate the answer you receive.
Ask Curtis B. Your Own Question
Curtis B.
Curtis B., Technician
Category: Small Engine
Satisfied Customers: 13581
Experience:  have worked on and around most engine models for 35 yrs./Polaris ATV expert
30244710
Type Your Small Engine Question Here...
Curtis B. is online now
A new question is answered every 9 seconds

Honda Gxv 530 16 hp on simplicity regent. Had in to dealer

Customer Question

Honda Gxv 530 16 hp on simplicity regent. Had in to dealer to service because it seems to run too rich and flood out,leaving no power.i think he put a new float in carb. Still not running right almost like water in gas. Ideas short of new carb? Can thy be rebuilt?
Submitted: 2 years ago.
Category: Small Engine
Expert:  Curtis B. replied 2 years ago.
Welcome to JUST ANSWER small engines, let me try to help you !! Have you ran a cylinder test? This being a twin engine, it may not be firing on both cylinders. Loosen the spark plug wires and with engine idling, remove one spark plug wire at a time. If engine dies when one is removed, the opposite cylinder is not firing. If that is the case, check it for spark and compression.
Customer: replied 2 years ago.
I did not, as it seems to run fine when it first starts up. Smooth, but after it is cutting under heavy load it runs very rough, like it is running too rich. Sometimes if it kills it will not restart until it sits for a few minutes.
Expert:  Curtis B. replied 2 years ago.
It may not be dropping a cylinder, but it needs to be checked
Expert:  Curtis B. replied 2 years ago.
These engines run smooth on just one cylinder!
Customer: replied 2 years ago.
I will do that tomorrow
Expert:  Curtis B. replied 2 years ago.
Ok, let me know!
Customer: replied 2 years ago.
I checked and both cylinders are firing. When I remove plug wire I just lost RPM but ran fine.
Expert:  Curtis B. replied 2 years ago.
Do you get any black smoke? Which would indicate flooding. Is choke flap staying fully open?
Customer: replied 2 years ago.
Both are firing at slow speed no load, and cold. Do you think it could be one of the coils? How do you trouble shoot for a bad coil?
Customer: replied 2 years ago.
Are the coils affected adversely when they get hot?Keith
Customer: replied 2 years ago.
I did not see black smoke but the exhaust did smell of un burnt raw gas
Expert:  Curtis B. replied 2 years ago.
Coils can quit when it gets hot. You would have to test when it is acting up, get a spark tester , to make it easier.