How JustAnswer Works:
  • Ask an Expert
    Experts are full of valuable knowledge and are ready to help with any question. Credentials confirmed by a Fortune 500 verification firm.
  • Get a Professional Answer
    Via email, text message, or notification as you wait on our site.
    Ask follow up questions if you need to.
  • 100% Satisfaction Guarantee
    Rate the answer you receive.
Ask Curtis B. Your Own Question
Curtis B.
Curtis B., Technician
Category: Small Engine
Satisfied Customers: 13581
Experience:  have worked on and around most engine models for 35 yrs./Polaris ATV expert
30244710
Type Your Small Engine Question Here...
Curtis B. is online now
A new question is answered every 9 seconds

I had not run my L130 much in the last coyple of years. I put

Customer Question

I had not run my L130 much in the last coyple of years. I put in a ne battery, added oil, fresh gas and gas additive. It ran great the 1st 3 or 4 passe and then started popping and smoking. I turned it off for a while but it doesn't want to start now. What am I doing wrong.
Submitted: 2 years ago.
Category: Small Engine
Expert:  Ranwell1 replied 2 years ago.
Most likely the problem is that since it had been sitting for that long, there is dirt or gum or varnish inside the carburetor that is plugging up or restricting the small passages in the carburetor. It may not be getting enough fuel to the engine. THis can cause the poping and smoking. Also the same reasons can caruse the carburetor to flood and get too much gas in the engine at the same time. THis can cause the smoking. And YEs you can have not enough fuel and too much gas at the same time.
Expert:  Ranwell1 replied 2 years ago.
You will most likely have to have the carburetor cleaned and rebuilt befor it is going to run correctly. Please leave me a good rating as this is the only way that this site pays me for my time.