How JustAnswer Works:
  • Ask an Expert
    Experts are full of valuable knowledge and are ready to help with any question. Credentials confirmed by a Fortune 500 verification firm.
  • Get a Professional Answer
    Via email, text message, or notification as you wait on our site. Ask follow up questions if you need to.
  • 100% Satisfaction Guarantee
    Rate the answer you receive.
Ask Peter Bagley Your Own Question
Peter Bagley
Peter Bagley, Toyota mastertech
Category: Saturn
Satisfied Customers: 814
Experience:  master tech at Toyota dealer
24571351
Type Your Saturn Question Here...
Peter Bagley is online now
A new question is answered every 9 seconds

This morning my wife went to leave for work and the key fob

Customer Question

This morning my wife went to leave for work and the key fob would not unlock the car. She used the key to unlock the door. When she went to start the car, there was no power. Gauges were off, no radio, no lights. This has happened before. Then a few seconds later the power returned and she started the car right up. New ECM, about 6 months old, new battery about 6 months old. Sometimes while driving, the radio only will shut off and turn on, with the clock reset, but the car does not die. Not sure where to look and see what it wrong. 2009 Saturn Vue XE 2.4l
JA: Is the power loss consistent, or does it fluctuate?
Customer: Fluctuate
JA: What is the model/year of your Saturn?
Customer: 2009 Vue 2.4L XE
JA: Are you fixing your VUE yourself? What have you tried so far?
Customer: I am trying to fix myself. New Engine Control Module. New Battery. Cleaned Battery Terminals and tightened.
JA: Anything else you want the mechanic to know before I connect you?
Customer: No
Submitted: 1 month ago.
Category: Saturn
Expert:  Peter Bagley replied 1 month ago.

Hello and welcome to just answer, my name is ***** ***** master tech here to help. I cannot see or hear your vehicle so I rely on your patience and input to my questions so I can help you better. I read your notes and have a few questions before we proceed.

Expert:  Peter Bagley replied 1 month ago.

I know you said you checked the cable terminals but did you check the other ends of those cables for corrosion and tightness? some times it is good to disconnect them there and clean and reinstall them to make sure. The other thing is look for any corrosion around the fuse block.Do these things and get back to me if you need further assistance.

Customer: replied 1 month ago.
I did not check connections and the fuse block for corrosion. I should have time to look into it tonight. Do you have any other recommendation while I am under the hood?
Expert:  Peter Bagley replied 1 month ago.

Do that first and get back to me as I feel it is an intermittent power loss It may be either corrosion bad connection or possibly a failing relay. The other thing you can do is what we call a wiggle test. Have the key in on position and have someone sit in car with items that normally fail when this happens and you start to wiggle all the main wiring harness that goes from the fuse block under the hood to the firewall and see if those items act up. Let me know after you do all this if you need further help.