How JustAnswer Works:
  • Ask an Expert
    Experts are full of valuable knowledge and are ready to help with any question. Credentials confirmed by a Fortune 500 verification firm.
  • Get a Professional Answer
    Via email, text message, or notification as you wait on our site. Ask follow up questions if you need to.
  • 100% Satisfaction Guarantee
    Rate the answer you receive.
Ask Dan Your Own Question
Dan
Dan, Technician
Category: Saturn
Satisfied Customers: 24587
Experience:  Independent Shop Experience, 2 Year Automotive Diploma, & Access to Information Database
17871496
Type Your Saturn Question Here...
Dan is online now
A new question is answered every 9 seconds

I have a 06 saturn vue with a 2.2L ecotec and a 5 speed

Customer Question

I have a 06 saturn vue with a 2.2L ecotec and a 5 speed manual transmission. I have a rough idle and heavy power loss especially on inclines. When driving i have to push the accelerator to the floor to get up to speed. I have already replaced the timing chain, guides, and tensioners for the camshafts amd balance shafts. In addition, i replaced the intake and throttle body gaskets, spark plugs, and spark plug wires. The catalytic converter failed and i replaced it with a straight pipe.
JA: Has the clutch been slipping? Are you having any trouble shifting?
Customer: No shift issues, just takes a long time to build up enough speed to shift. Please note i can really smell gas due to a rich mixture and have a misfire engine code.
JA: Are you fixing your VUE yourself? What have you tried so far?
Customer: Please reread my complaint
JA: Anything else you want the mechanic to know before I connect you?
Customer: No
Submitted: 2 months ago.
Category: Saturn
Expert:  Dan replied 2 months ago.

Hello, my name is ***** ***** I'm here to help get your problem solved.

Expert:  Dan replied 2 months ago.

What codes are you getting? Did timing chain break/jump while engine was running?

Customer: replied 2 months ago.
The chain was not broken and felt tight but i replaced it anyway. After i did the engine ran better but still not right
Customer: replied 2 months ago.
Trouble codes are PO171 and PO300
Expert:  Dan replied 2 months ago.

P0171 is the key here, considering you replaced intake this sounds like a worn fuel pump assuming there are no vacuum leaks you missed. Fuel pressure should be at least 50 psi key on engine off, if low replace the pump. Let me know if you have questions or would like replacement instructions for pump, thanks.

Customer: replied 2 months ago.
What should i do if tge fuel pressure checks out?
Expert:  Dan replied 2 months ago.

Double check for vacuum leaks and see if vehicle runs better with front oxygen sensor unplugged, if so replace. Let me know how it goes or if you run into more questions. Thanks.

Expert:  Dan replied 2 months ago.

Ever get it figured out?

Customer: replied 2 months ago.
Unfortunately not yet. I do not have the equipment to test fuel pressure or the funds right now to take it to a shop as ive already put around 400.00 into it. I used a soapy solution to check for leaks around seals and hoses but didnt find anything. As for the o2 sensor its been disconnected since i pulled the cat out and hasnt run any differently.
Expert:  Dan replied 2 months ago.

I think problem is fuel pump, they are cheap enough on ebay where it would probably be worth just replacing yourself. Let me know how it goes. Thanks.

Customer: replied 2 months ago.
Thank you for your advice and follow up. Ill price one out and try to get a pressure check done asap.
Expert:  Dan replied 2 months ago.

Parts stores often barrow out fuel pressure testers for free too. Keep me updated.

Expert:  Dan replied 2 months ago.

Just letting you know I do not get compensated for information or time until you rate answer. Thanks.