How JustAnswer Works:
  • Ask an Expert
    Experts are full of valuable knowledge and are ready to help with any question. Credentials confirmed by a Fortune 500 verification firm.
  • Get a Professional Answer
    Via email, text message, or notification as you wait on our site. Ask follow up questions if you need to.
  • 100% Satisfaction Guarantee
    Rate the answer you receive.
Ask Gm Tech (Cam) Your Own Question
Gm Tech (Cam)
Gm Tech (Cam), Saturn Mechanic
Category: Saturn
Satisfied Customers: 29534
Experience:  GM Grand Master Technician 2007. 14 years experience.
10949255
Type Your Saturn Question Here...
Gm Tech (Cam) is online now
A new question is answered every 9 seconds

Saturn Outlook XE: I changed the input speed sensor in my 2009

Customer Question

I changed the input speed sensor in my 2009 outlook xe. Popping codes po716 and po716. Still shifting crappy or not accelerating sometimes. Doesn't happen in the mornings just on my way home in the evening. Changing sensor fid not change codes. Any idea what else may be wrong?
Submitted: 2 years ago.
Category: Saturn
Expert:  Gm Tech (Cam) replied 2 years ago.
Hi there, I am Cam. Can you tell me if you had any repairs done prior to this happing? Did it happen all at once or occasionally at first or what?
Customer: replied 2 years ago.
Nothing done prior. I just happen all at once one day 3 weeks ago. Had it towed home. Happens now only in the afternoon.
Expert:  Gm Tech (Cam) replied 2 years ago.
Ok so looking through the informant on that fault code there are 4 possible issues. fIrst as you have tried, the sensor., Second is the wiring inside to the sensor, third is the control valve body assembly that is the module, and fourth is a misaligned or damaged clutch housing which has the ring spinning in the transmission that the sensor reads.
Customer: replied 2 years ago.
New wiring for the sensor was installed. Would any of these other possibilities indicate intermittent problems?
Expert:  Gm Tech (Cam) replied 2 years ago.
intermittent does tent to support the module as being the issue rather than the clutch housing.
Customer: replied 2 years ago.
I will check the clutch housing then. Thank you!
Expert:  Gm Tech (Cam) replied 2 years ago.
Is there more I can get you today?
Expert:  Gm Tech (Cam) replied 2 years ago.
Is there more I can get you today?
Customer: replied 2 years ago.
No thank you!
Expert:  Gm Tech (Cam) replied 2 years ago.
Please reply back if you need additional help or information regarding this issue. If there is nothing more I can get for you today, then please rate me 5 starts/faces if my answer was helpful. You can reopen/reply to this thread directly to me at any time by replying to it and I will respond as soon as I am able. Please keep in mind that as experts on this site, we are only compensated for our time spent helping customers rating 3-5 stars/faces. Be sure to bookmark this page as a favorite (CTRL D on PC and CMD D on Mac) to reply with results or ask more if you need. Thanks again for using Just Answer. Cam.
Expert:  Gm Tech (Cam) replied 2 years ago.
Please reply back if you need additional help or information regarding this issue. If there is nothing more I can get for you today, then please rate me 5 starts/faces if my answer was helpful. You can reopen/reply to this thread directly to me at any time by replying to it and I will respond as soon as I am able. Please keep in mind that as experts on this site, we are only compensated for our time spent helping customers rating 3-5 stars/faces. Be sure to bookmark this page as a favorite (CTRL D on PC and CMD D on Mac) to reply with results or ask more if you need. Thanks again for using Just Answer. Cam.