How JustAnswer Works:
  • Ask an Expert
    Experts are full of valuable knowledge and are ready to help with any question. Credentials confirmed by a Fortune 500 verification firm.
  • Get a Professional Answer
    Via email, text message, or notification as you wait on our site. Ask follow up questions if you need to.
  • 100% Satisfaction Guarantee
    Rate the answer you receive.
Ask Randall Your Own Question
Randall
Randall, RVIA Certification
Category: RV
Satisfied Customers: 11918
Experience:  RVDA/RVIA Master Certified Technician with many years experience.
21664427
Type Your RV Question Here...
Randall is online now
A new question is answered every 9 seconds

Brand new rockwood mini with suburban sw6del water heater

Customer Question

brand new rockwood mini with suburban sw6del water heater that wont light...there was no pdi done prior to delivery...long story, but wondering if something wasnt done to get it to work..gas is getting to it, light on control panel inside by switch has a light that goes on and off like its trying to light, but dont hear the igniter...
JA: Just to clarify, what are the exact lights you're talking about?
Customer: the control panel inside where the switch is ..when you flip the water heater on theres a red light that goes out then comes back on..by the dsi switch
JA: What year is your MINI?
Customer: 2018
JA: Are you fixing your MINI yourself? What have you tried so far?
Customer: have only tried to call a warranty person as dealer is 100 miles away
JA: Anything else you want the mechanic to know before I connect you?
Customer: no
Submitted: 1 month ago.
Category: RV
Expert:  Randall replied 1 month ago.

Hi! My name is ***** ***** I can assist you with this. I may need some additional information from you first in order to give a complete answer.

Expert:  Randall replied 1 month ago.

Does it spark and try to light or not at all? And give me some time to respond as I am on another call here.

Customer: replied 1 month ago.
No sound of an ignitor at all
Expert:  Randall replied 1 month ago.

Good voltage in the battery? Plugged into shore power or not.

Customer: replied 1 month ago.
dont wish to call as this is a warranty issue....just trying to see if its something obvious...as the unit was not pdi'd...I can tell, and the delivery was fast and crazy...not even cleaned up so Im thinking its possible they didnt do something at delivery
Customer: replied 1 month ago.
everything good..plugged into power...but the gas use side is the problem
Expert:  Randall replied 1 month ago.

T​hat sounds like either the board is bad or may have a bad connection. See the attached link for a copy of the Suburban Service Manual. Print this out so you have it. http://bryantrv.com/docs2/docs/hflamefurn04.pdf

Customer: replied 1 month ago.
thanks!
Expert:  Randall replied 1 month ago.

The control board is on the rear of the water heater on the wall or ceiling of the compartment. Unplug it and plug it back in again. See it that corrects this. Too bad they didn't do the PDI service! Chew them out good! Maybe call the OEM and report this.

Customer: replied 1 month ago.
not an atwood its a suburban..
Expert:  Randall replied 1 month ago.

You are most welcome! Whooops! That was the link from another question. Be right back.....

Expert:  Randall replied 1 month ago.

If you have an Atwood Furnace that might help!

Customer: replied 1 month ago.
Yeah...the company is BEST RV in Turlock CA...known for good prices and bad service....it was 110 outside and all were in a hurry...but...its 100 miles away so trying to see if its simple..its a Suburban sw6del
Expert:  Randall replied 1 month ago.

Did you get that link to the correct manual?

Customer: replied 1 month ago.
he's checking the plug in now....we did get a manual...just checking to see if there was something obvious they were supposed to hook up, drain out or switch on during pdi...it came winterized so we werent sure if it had something to do with that...would the electric side work even if the gas side didnt?
Expert:  Randall replied 1 month ago.

If the water heater is empty it will burn out the heating element quickly. Water in it now? If so, check the master switch on the outside down in the lower left hand corner. Be sure that is on.

Expert:  Randall replied 1 month ago.

Just checking back in to see if you were able to sort this out? If you need more, please get back to me later.