How JustAnswer Works:
  • Ask an Expert
    Experts are full of valuable knowledge and are ready to help with any question. Credentials confirmed by a Fortune 500 verification firm.
  • Get a Professional Answer
    Via email, text message, or notification as you wait on our site. Ask follow up questions if you need to.
  • 100% Satisfaction Guarantee
    Rate the answer you receive.
Ask Randall Your Own Question
Randall
Randall, RVIA Certification
Category: RV
Satisfied Customers: 11931
Experience:  RVDA/RVIA Master Certified Technician with many years experience.
21664427
Type Your RV Question Here...
Randall is online now
A new question is answered every 9 seconds

I have a 2003 Coachmen Leprechaun 314SS. I just replaced the

Customer Question

I have a 2003 Coachmen Leprechaun 314SS. I just replaced the coach batteries and now the latching relay isn't working. Can you tell me where the fuses are for this model?
JA: How many miles are on the car? Has the car been starting normally?
Customer: The vehicle starts and runs normally, but the coach battery disconnect will not operate unless the vehicle key is on.
JA: What is the model of your '03 RV?
Customer: It is a Coachmen Leprechaun 314SS
JA: Are you fixing your RV yourself? What have you tried so far?
Customer: I just replaced the coach batteries which are fully charged. I haven't tried to do anything except look for the latching relay fuse.
JA: Anything else you want the mechanic to know before I connect you?
Customer: The batteries are connected in parallel as required.
Submitted: 2 months ago.
Category: RV
Expert:  Randall replied 2 months ago.

Hi! My name is ***** ***** I can assist you with this. I may need some additional information from you first in order to give a complete answer.

Expert:  Randall replied 2 months ago.

If you are talking about the battery disconnect solenoid module, they are on the unit. Some will have one and some have two. Usually 7.5 amp fuses. Double check the battery cables and hookups to be sure they are correct. Easy to drop a cable off and not get it hooked back up again or get a positive cable over on the negative side.

Expert:  Randall replied 2 months ago.

That is if you have ones made by Intellitec. If you have those made by RV Custom Products, those are on the control module in the Battery Control Center. It may also be a tripped shortstop breaker causing this. Small black button on the end that has to be pushed back in again. See the attached link photo. https://www.bing.com/images/search?view=detailV2&ccid=BqT81%2fi2&id=8D4939A7F0965679E3E29C89B963B0D9C24CDC15&thid=OIP.BqT81_i2snOEu0WIlAltMAEsEY&q=shortstop+breaker+photo&simid=608020010426568081&selectedIndex=0

Expert:  Randall replied 2 months ago.

J​ust following up to see if perhaps you missed my earlier responses to your question? Easy to do considering the volume of e-mail that most of us get every day! If you need me to resend it please let know. Thanks!