How JustAnswer Works:
  • Ask an Expert
    Experts are full of valuable knowledge and are ready to help with any question. Credentials confirmed by a Fortune 500 verification firm.
  • Get a Professional Answer
    Via email, text message, or notification as you wait on our site. Ask follow up questions if you need to.
  • 100% Satisfaction Guarantee
    Rate the answer you receive.
Ask Robert Your Own Question
Robert
Robert, RV Mechanic
Category: RV
Satisfied Customers: 13511
Experience:  18 yrs. RV experience including Cummins North West, Country Coach, Monaco Coach - vendor certified.
3862310
Type Your RV Question Here...
Robert is online now
A new question is answered every 9 seconds

My Monaco has lost the tack,speedometer and other gauges

Customer Question

my Monaco has lost the tack,speedometer and other gauges ,and the check trans light is on and the trans selector shows two cat eyes instead of N R or 1 2 3 4 5 6 .
JA: I'll do all I can to help. How long have you been dealing with this?
Customer: two weeks
JA: Do you plan on doing the work yourself?
Customer: yes
JA: Anything else we should know to help you best?
Customer: it a 2007 Monaco knight
Submitted: 2 months ago.
Category: RV
Expert:  Robert replied 2 months ago.

Hi, I'm Robert. Welcome to JustAnswer. I'm reviewing your question now and will post back with your reply momentarily.

Expert:  Robert replied 2 months ago.

The cateye display indicates that the shifter can't communicate with the TCM for the transmission, with all the other gauges that are out it appears you have a blown fuse or wiring issue with the system. SO to start I would disconnect the battery cables for a bout 20 mins, make sure ALL the cables are clean and tight when you put them back on. A dirty loose cable can cause this. Make sure you also have over 12 volts at the batteries, low voltage can cause all kinds of issues as well.

Then you have to start checking the fuses and wiring harness going into the dash. Start at the chassis fuse box, get a 12 volt test light, turn the ignition ON and probe each fuse for power the chassis fuse box should be outside, check any grounds you see to the frame. Follow the main harness into the dash and check for any loose wire connector plugs and check your grounds as well. Sometimes you will find plug connectors that plug together for the DC wiring and they can vibrate loose or get corroded if they are outside, pull them apart and check the pins.

Beyond that you might want to get a hold of Monaco on Monday and see if they are wiling to give up a print to help you troubleshoot this, I do not have any or I would give it to you....

Robert

Expert:  Robert replied 2 months ago.

Hi... Was just checking in to see if my answer helped??? IF you have more questions or concerns please feel free to contact me..

Thanks, Robert