How JustAnswer Works:
  • Ask an Expert
    Experts are full of valuable knowledge and are ready to help with any question. Credentials confirmed by a Fortune 500 verification firm.
  • Get a Professional Answer
    Via email, text message, or notification as you wait on our site. Ask follow up questions if you need to.
  • 100% Satisfaction Guarantee
    Rate the answer you receive.
Ask Randall Your Own Question
Randall
Randall, RVIA Certification
Category: RV
Satisfied Customers: 11909
Experience:  RVDA/RVIA Master Certified Technician with many years experience.
21664427
Type Your RV Question Here...
Randall is online now
A new question is answered every 9 seconds

I have a 2002 Keystone Montana with a black water tank flush

Customer Question

I have a 2002 Keystone Montana with a black water tank flush system. The hose mounts to the side of the trailer. When I try to flush the tank, water flows through the anti-sihon valve, but no water flows out of the tank. There seems to be a blockage somewhere beyond the anti-siphon
JA: How many miles are on the car? Have you noticed any leaks lately?
Customer: valve. Can you give me any advice on how to find this problem?
JA: Are you fixing your Montana yourself? What have you tried so far?
Customer: The ant-siphon valve was installed backwards and we corrected that. Beyond that I am not sure what to do. Following the piping into the tank is even difficult. So beyond that----nothing!
JA: Anything else you want the mechanic to know before I connect you?
Customer: That's all I know.
Submitted: 2 months ago.
Category: RV
Expert:  peterpete190 replied 2 months ago.

Hi my name is ***** ***** I will be happy to assist with this today.In some cases I may need more info to assist better.I apologize for any delay.My info is somewhat limited on your model here but I had seen no one else has responded and would like to see if I can help here.If at any time you feel that I cannot help with this please let me know.

It is possible the restriction is in the tank itself.I have seen build up restrict the spray ports in the tank and causes this fault here in lots of cases.If the hoses all look o.k. and the anti siphon is installed correctly I suspect this is the cause here and it may need to be removed and manually cleaned ( by a professional in a safe and sanitary way ) to then clear up and resolve this issue here.In a worse case scenario the tank may need replaced.

If more help is needed, use the reply tab to continue our conversation. If no further assistance is needed, kindly rate my service,your 5 star rating is appreciated ( should be a link to click on here or above).You can rate at any time and we can continue to work on your question as this will not close out your question.Keep in mind in some cases it can be difficult to fully diagnose or help repair your vehicle without seeing it and I work on delivering the best possible answer from what I see to work with.

Thanks Pete

Customer: replied 2 months ago.
The answer was not helpful to me. It was intuitive obvious that those things were possible. I will not be using this service again.
Expert:  peterpete190 replied 2 months ago.

I will open your question for others here to see if anyone else can assist further.

I will open your question up for others here to see if someone else can assist further on this as there may be others here that may have more info on what to check or do with this issue.I hope you can get this resolved with ease.No need to reply to my last post here unless it is a last resort as it will keep your question locked to me and others will not be able to view it.If you feel you want to continue to work with me on this feel free to reply at any time but keep in mind in some cases it can be difficult to fully diagnose or help repair this without seeing your vehicle.

Thanks Pete

Expert:  Randall replied 2 months ago.

Are you sure that the valve out of the tank is actually open? It may be that the blade came loose from the handle or cable. This happens more than many would realize. Or I have seen cases in my shop where the plastic disc that was cut out for the entry of the black waste pipe was left in there and got washed down to the mouth of the tank and blocked the waste and water from exiting the tank. Depending on which chemical you use it can be just a large amount of undigested waste that has accumulated at the mouth of the tank. I use Happy Camper Extreme Cleaner in my shop for all my customers and that is the best for cleaning and breaking down any debris. Available on their website or Amazon if your dealer doesn't stock it. And then you can try using a clip on waste valve and HydroFlush unit so you can back flush the tank some from the hose connection. That would help push anything back from the mouth of the tank and it is clear so you can tell what is coming out once you open up the clip on valve. Most RV shops sell these or numerous companies online. Those would be the steps I would take in my shop here. If the valve is broken, that will become apparent quickly and then some steps taken to repair or replace it. Taking some of the underbelly down is needed to access that area. Hope that gives you a place to start. I wouldn't judge our service by one reply. I have successfully assisted over 11,000 customers over the last 8 years and many are repeat customers. They love getting an immediate solution so they don't have to wait weeks trying to get into a shop and the price is far less than shops charge so it saves them money. Please let me know if I can assist further here. All follow ups are included in our fee. We do offer a 100% satisfaction guarantee so you risk nothing really.

Expert:  Randall replied 2 months ago.

Just checking back to see if perhaps you may have missed my previous response to your question? Easy to do considering the volume of e-mail that most of us get every day! If you need me to resend this, please let me know. Thanks!