How JustAnswer Works:
  • Ask an Expert
    Experts are full of valuable knowledge and are ready to help with any question. Credentials confirmed by a Fortune 500 verification firm.
  • Get a Professional Answer
    Via email, text message, or notification as you wait on our site. Ask follow up questions if you need to.
  • 100% Satisfaction Guarantee
    Rate the answer you receive.
Ask Robert Your Own Question
Robert
Robert, RV Mechanic
Category: RV
Satisfied Customers: 13511
Experience:  18 yrs. RV experience including Cummins North West, Country Coach, Monaco Coach - vendor certified.
3862310
Type Your RV Question Here...
Robert is online now
A new question is answered every 9 seconds

I have a 2013 fleetwood storm the slide out will not work,

Customer Question

i have a 2013 fleetwood storm the slide out will not work
JA: Are you fixing your Fleetwood yourself? What have you tried so far?
Customer: yes and i found a battery disconnect switch that has no reading on one side
JA: Have you tested the battery with a voltmeter? And can you see if it's leaking or not?
Customer: yes and the meter reads on the right side no drop and no reading on the left side
JA: Anything else you want the mechanic to know before I connect you?
Customer: not at this time
Submitted: 2 months ago.
Category: RV
Expert:  Robert replied 2 months ago.

Hi, I'm Robert. Welcome to JustAnswer. I'm reviewing your question now and will post back with your reply momentarily.

Expert:  Robert replied 2 months ago.

Do you have an interior switch for the disconnect if so then you have a solenoid valve that will allow power into the RV when you hit the disconnect switch. Hit the switch and listen for the solenoid, sometimes you can hear it click. IF you can not locate it by sound go to the battery and follow the cables to the solenoid. Once you find the solenoid you will see two LARGE posts, get an insulated wire and jump the posts and see if the power comes on or the slide-room works. If so the solenoid is bad.

Normally when the solenoid fails you would have NO power at all not to just the slide-room. IF all your other power is working but the slide-room make sure the vehicle is in park, the parking brake is set, try running the engine as well, some require the engine running and others do not.

Go to the battery and look for a tripped breaker, below is a picture, sometimes you will find one between the battery and slide-room. Most have a tiny tab on them that will pop out when they trip, as a general rule it would be 18" from the battery and can be on the frame OR inside a battery control box with other fuses, breakers and possibly the disconnect solenoid. To test you would want to see the same voltage on each post to chassis ground, if one side has voltage and the other does not or low voltage it is the problem.

IF you have more questions or concerns please feel free to contact me, I am around daily and respond WHEN I can......

IF you are satisfied with my efforts please feel free to select a STAR rating on the page. Robert

Breaker.

Expert:  Robert replied 2 months ago.

Hi... Was just checking in to see if my answer helped??? IF you have more questions or concerns please feel free to contact me..

Thanks, Robert