How JustAnswer Works:
  • Ask an Expert
    Experts are full of valuable knowledge and are ready to help with any question. Credentials confirmed by a Fortune 500 verification firm.
  • Get a Professional Answer
    Via email, text message, or notification as you wait on our site.
    Ask follow up questions if you need to.
  • 100% Satisfaction Guarantee
    Rate the answer you receive.
Ask Robert Your Own Question
Robert
Robert, RV Mechanic
Category: RV
Satisfied Customers: 13283
Experience:  18 yrs. RV experience including Cummins North West, Country Coach, Monaco Coach - vendor certified.
3862310
Type Your RV Question Here...
Robert is online now
A new question is answered every 9 seconds

I have an Atwood 7920-II furnace in my camper. It worked

Customer Question

I have an Atwood 7920-II furnace in my Lance camper. It worked fine the last camping trip but now does the following: When the thermostat tries to fire the furnace up...the fan comes on...the burner ignites...and the furnace runs for about 15 seconds before the 5amp circuit breaker trips.
JA: Have you checked all the fuses? Do you have a wiring diagram?
Customer: I replaced the 5amp circuit breaker. The new breaker trips, too, in the same time period.
JA: What is the model of your '15 RV?
Customer: The furnace model is: 7920-II
JA: Are you fixing your RV yourself? What have you tried so far?
Customer: Yes, I am fixing it myself. I have checked all the wiring and have replaced the circuit breaker.
JA: Anything else you want the mechanic to know before I connect you?
Customer: That's it.
Submitted: 6 months ago.
Category: RV
Expert:  Robert replied 6 months ago.

Hi my name is Robert.....

Sounds like a bad fan motor or circuit board on the furnace, I would think if it was the fan motor it would trip the breaker prior to it firing off.

I would find the circuit board and pull the connector on the board, clean the contacts on the board with a pencil eraser, sometimes that can be a weak link, make sure all the wiring looks good. After that I would have that board tested, most RV shops/stores have a special board tester and can tell if that is the issue. IF the board checks out good and it is still tripping the breaker you could have a bad fan motor. IF you like I can give you a service manual on this as well...

Hope this helps, IF you have more questions or concerns please feel free to contact me.... Robert

Expert:  Robert replied 6 months ago.

Hi.... Was just checking in to see if my answer helped?? Please let me know if you have more questions or concerns....

Robert

Related RV Questions