How JustAnswer Works:
  • Ask an Expert
    Experts are full of valuable knowledge and are ready to help with any question. Credentials confirmed by a Fortune 500 verification firm.
  • Get a Professional Answer
    Via email, text message, or notification as you wait on our site. Ask follow up questions if you need to.
  • 100% Satisfaction Guarantee
    Rate the answer you receive.
Ask Robert Your Own Question
Robert
Robert, RV Mechanic
Category: RV
Satisfied Customers: 13467
Experience:  18 yrs. RV experience including Cummins North West, Country Coach, Monaco Coach - vendor certified.
3862310
Type Your RV Question Here...
Robert is online now
A new question is answered every 9 seconds

I have a 2011 Fleetwood southwind with both a/c not working

Customer Question

hello, I have a 2011 Fleetwood southwind with both a/c not working at times. (random) every now and then I get an error coming up on my thermostat. I put a new stat on and same problem. what can I try next?
Submitted: 1 year ago.
Category: RV
Expert:  Robert replied 1 year ago.

Hi my name is Robert...

What is the model or part number on the thermostat and what error are you getting?

Thanks, Robert

Customer: replied 1 year ago.

Both a/c runs the compressor does not engage. The t-stat# ***** RVP#8330D331.

Expert:  Robert replied 1 year ago.

OK

The first thing that I thought of when I saw your question was it being random, one thing I have seen with that particular set up is if you have lights with ballast in them OR you have any chargers plugged in they can cause interference. So I would try that first, unplug any chargers and try leaving the lights off if you have the ballasts in them.

Beyond that it could be a loose connection or issue wit the circuit board inside the AC unit, I do have a troubleshooting tree that you can follow, click HERE to view see the section on no compressor operation, it should help out some. IF you have more questions or concerns please feel free to contact me..... Robert

Expert:  Robert replied 1 year ago.

HI... I see you have not selected a rating, if you need more help please let me know... Robert