How JustAnswer Works:
  • Ask an Expert
    Experts are full of valuable knowledge and are ready to help with any question. Credentials confirmed by a Fortune 500 verification firm.
  • Get a Professional Answer
    Via email, text message, or notification as you wait on our site. Ask follow up questions if you need to.
  • 100% Satisfaction Guarantee
    Rate the answer you receive.
Ask Robert Your Own Question
Robert
Robert, RV Mechanic
Category: RV
Satisfied Customers: 13515
Experience:  18 yrs. RV experience including Cummins North West, Country Coach, Monaco Coach - vendor certified.
3862310
Type Your RV Question Here...
Robert is online now
A new question is answered every 9 seconds

Driving on interstate and engine lost power, got to side of

Customer Question

Driving on interstate and engine lost power, got to side of road but motorhome is still in sixth gear, can't get it into neutral or restart. We hane a 2005 Monaco Camelot
Submitted: 1 year ago.
Category: RV
Expert:  Robert replied 1 year ago.

Hi my name is Robert...

You might be limited on this. What you can try to do is disconnect the chassis battery cables for a few mins and see if the control module for the transmission resets, sometimes that works and other times it does not, make sure all your battery cables are also clean and tight and the voltage is good at the batteries. Beyond that you might be able to pull codes on the transmission pad if it is an Allison. You would hold both the up and down arrows at the same time and the first info is the transmission level, it will say H I and a number or L O and a number, or OK. The pad will do a count down and flash a 8 and then down to zero, hitting the buttons a second time would allow you to see if any codes are present, the transmission needs to be warmed up as well for the level check, what I do not know is if it will allow you to check for codes if it is still in 6th gear. Might need a mobile service to come out on this one if the battery trick does not work. IF you have more questions or concerns please feel free to contact me... Robert

Customer: replied 1 year ago.
The transmission buttons are not lit up, all other gauges are. We have not disconnect the cables yet as you mentioned. We have been waitin 31/2 hrs for a service truck! Call us(###) ###-####
Expert:  Robert replied 1 year ago.

Sorry there is a additional fee for a phone service and I am a bit tied up right now where I can not do a phone call....

IS the transmission pad coming on at all? is it showing 6th gear or nothing at all. IF it is not showing anything then it could be a blown fuse in the Allison control box. IF the pad is showing the gear then I would try and disconnect the cables.

IF you would like to try another expert please let me know, I only get credit when you select a rating. Robert

Expert:  Robert replied 1 year ago.

Hi was just checking in to see if my answer helped, IF you have more questions or concerns please feel free to contact me...

Robert