How JustAnswer Works:
  • Ask an Expert
    Experts are full of valuable knowledge and are ready to help with any question. Credentials confirmed by a Fortune 500 verification firm.
  • Get a Professional Answer
    Via email, text message, or notification as you wait on our site.
    Ask follow up questions if you need to.
  • 100% Satisfaction Guarantee
    Rate the answer you receive.
Ask Robert Your Own Question
Robert
Robert, RV Mechanic
Category: RV
Satisfied Customers: 13361
Experience:  18 yrs. RV experience including Cummins North West, Country Coach, Monaco Coach - vendor certified.
3862310
Type Your RV Question Here...
Robert is online now
A new question is answered every 9 seconds

I have a 2002 monaco dynasty with aquahot. I have an

Customer Question

I have a 2002 monaco dynasty with aquahot. I have an overheating problem when driving not sitting still. I noticed that there are 2 returns inti the holding tank. The one on the right is fulling full force. The one on the left is not flowing at all. I just had anti freeze flushed and replaced and radiator fins cleaned by cummins dealer. travel 2500 miles on highway before problem started engine does not seem to be overheating but trans seems to be. Any ideas
Submitted: 1 year ago.
Category: RV
Expert:  Robert replied 1 year ago.

Hi my name is Robert.....

Are these return lines on the Aquahot or on the radiator? Did you have the engine coolant serviced?

Robert

Customer: replied 1 year ago.
that's my question where are they from. They are on radiator holding tank. One on right has full flow the one on left of holding tank has nothing. Engine coolant was flushed and replaced and radiator fins were cleaned
Expert:  Robert replied 1 year ago.

OK

IS the Aqua Hot blowing hot air in all zones? What Engine do you have on your Dynasty?

Robert

Customer: replied 1 year ago.
aquahot is functioning properly. Cummins ISL 400
Expert:  Robert replied 1 year ago.

OK

Wanted to ask about the aquahot as the engine coolant does in fact run through the auquahot and sometimes air can get trapped in the system, if that was the case then you might not get hot air coming out for your heating.

On the actual radiator you should have a top and bottom hose, can you feel flow through both of them? And just so I am clear you see two lines on the surge tank? Normally one would be a return and the other will vent to the ground....

Robert

Customer: replied 1 year ago.
There are three if you count overflow by radiator cap. The holding tank is pressurized, twoo inlets on top left and right of pressure cap, and a flow out on bottom to engine
Expert:  Robert replied 1 year ago.

It is possible the third is for the aqua hot system.

I am not sure if changing the coolant has anything to do with this if the transmission temp is running higher....

Have you checked the level for the transmission? Did you get a high temp alarm for the trans? How hot was it?

Robert

Customer: replied 1 year ago.
transmission was serviced last fall the fluid is full my temp was showing 250 degrees at one point and the holding tank was steaming up from the engine feed forcing the antl freeze out the pressure cap release line. I'm not sure if my idiot lights are working
Expert:  Robert replied 1 year ago.

OK

What I might do is go to the aqua hot, on the aqua hot will be some check valves, click HERE see page 24. I have seen an issue before if the air is not bleed from the aqua hot while doing the coolant service it can cause issues. I might start the engine and then go open the check valves and see if you get air coming out, if so let the air bleed off and then tighten them back up when you get flow.

IF you had an air pocket it could cause the issue you are having. On some of these engines they also used a coolant filter, it would be on the side of the engine next to the oil filter, on the housing for the filter is a valve, make sure the valve is open, they can be a pain to get at and the the valve handle should be running with the pipe. Also in that location make sure there is not another coolant valve, that valve would be round. The other issue would be if the coolant level was low.Many times when you do a coolant service you have to run the engine or test drive it so the thermostat opens up which means you have to add more coolant after a service. The coolant level should be at the proper mark in the tank.

I might get this looked at again and make contact with the shop that did the work to see if they would be willing to have this looked at somewhere close to you....

IF you have more questions or concerns please feel free to contact me... Robert

Customer: replied 1 year ago.
i'll ck the items you mentioned, the strange fact is I drove from Florida to California before problem started.
Expert:  Robert replied 1 year ago.

Understand and I am going off the fact the engine coolant was just changed it could be other items as well. So if it is nothing I mentioned I would really have it looked at...

IF you are satisfied with my efforts please feel free to select a rating, it is the only way I get credit for helping, also feel free to follow up if needed.... Robert