How JustAnswer Works:
  • Ask an Expert
    Experts are full of valuable knowledge and are ready to help with any question. Credentials confirmed by a Fortune 500 verification firm.
  • Get a Professional Answer
    Via email, text message, or notification as you wait on our site. Ask follow up questions if you need to.
  • 100% Satisfaction Guarantee
    Rate the answer you receive.
Ask peterpete190 Your Own Question
peterpete190
peterpete190, Auto Technician
Category: RV
Satisfied Customers: 29112
Experience:  Over 17 years diagnosing and repairing various model vehicles.
14928985
Type Your RV Question Here...
peterpete190 is online now
A new question is answered every 9 seconds

1999 Southwind RV w-v10 and e40d trans. Engine surges upon

Customer Question

1999 Southwind RV w-v10 and e40d trans. Engine surges upon take off, once going caused the trans to hard shift. The Ford dealer has tested and it shows no codes....However while at idle and sitting the VMS? showes the vehicle is traveling down the road at 40+mph. The Ford dealer can't find the problem?
Submitted: 2 years ago.
Category: RV
Customer: replied 2 years ago.
1999 Southwind RV w-v10 and e40d trans. Engine surges upon take off, once going caused the trans to hard shift. The Ford dealer has tested and it shows no codes....However while at idle and sitting the VMS? shows the vehicle is traveling down the road at 40+mph. The Ford dealer can't find the problem? They have had the veh. for 3 weeks with several calls to Ford factory Tech's. I am taking the RV from them and to Carmanita Ford in Santa Fe Springs in Ca. They specialize in trucks only and feel the can fix the problem.. This is very frustrating because whatever the problem is, it is most likely simple.....finding it is the problem....I NEED HELP!!! it's going on a month and the experts can't find the problem?
Expert:  peterpete190 replied 2 years ago.
My name is ***** ***** I am a professional here at Just Answer. I noticed that your question was not getting a response and thought I would see if you still need help with this.I apologize for the delay and I hope I can still assist you with this here.
My info is limited on your model here but I see no one else has responded and thought I would see if I can help here.
This sounds like the common fault with the vehicle speed sensor.If this sensor or the sensor wiring is at fault this causes the false mph display as well as engine surging and transmission shifting issues.It can cause all of these faults as I have seen several times before.If they have not checked this to see if this is the cause here this needs done.
Thanks Pete
Customer: replied 2 years ago.
Thanks for the response, better late than never......i would like to believe they checked all of that. That said i'm limited on what they checked having not being there when they worked on it.
What i need to know is will i damage the engine/trans if i drive it with this problem?....i need to take it to another Ford dealer as the Ford dealer it's currently at obviously don't know how to repair it.
Expert:  peterpete190 replied 2 years ago.

Your welcome and I do apologize for the delay once again.

If excessive driving continues this can lead to more internal transmission issues over time but if you are simply brining it to a local dealer it should be o.k. To operate to the dealer.I wouldn't drive it to much though.

Thanks Pete