How JustAnswer Works:
  • Ask an Expert
    Experts are full of valuable knowledge and are ready to help with any question. Credentials confirmed by a Fortune 500 verification firm.
  • Get a Professional Answer
    Via email, text message, or notification as you wait on our site.
    Ask follow up questions if you need to.
  • 100% Satisfaction Guarantee
    Rate the answer you receive.
Ask Robert Your Own Question
Robert
Robert, RV Mechanic
Category: RV
Satisfied Customers: 13448
Experience:  18 yrs. RV experience including Cummins North West, Country Coach, Monaco Coach - vendor certified.
3862310
Type Your RV Question Here...
Robert is online now
A new question is answered every 9 seconds

I have a new 2014 palazzo with the "standard Freightliner chassis

Customer Question

I have a new 2014 palazzo with the "standard Freightliner chassis eith the 300/660 cummins." It is new and we are on the road. I am getting a "malfuction indicator light." Everything seems normal and all guages are in normal range, no loss of power or funny smells, all fluids at full level except fuel which is at half tank.
We are currently in Coeur d'Alene on our way home NW of Tacoma. ??
Submitted: 2 years ago.
Category: RV
Expert:  Robert replied 2 years ago.
Hi my name is Robert....
Really hard to say for sure why the indicator light has gone off, it can go off for many, many different reason, the best thing to do on this being a 2014 is have a Cummins shop hook up to the data port and see what codes are being stored. Anytime the light goes off the system should store a code, with the proper software a shop can see what the cause is. In the long run this saves time and money. IF the issue gets worse then the engine will de-rate and you would have a loss of power. So at this point I would say it is OK to drive but I would keep a close eye on everything. Hope this helps some... Robert